How to create a Lightning Node Alias?

Can someone advise how I can set my lightning node alias? I have tried it a few ways but get an error each time.



Moderator Edit: These steps are now obsolete in the new version, to summarize lnd.conf is used for non-UI settings and you can now change your alias directly from the UI in Lightning Node advanced settings! You may reference “Updating Your Lightning Node’s Alias” in our Official FAQ guide here
(as a note this is also different than the Umbrel dashboard username, changing this is also listed within the guide!)

Want to set an alias for your Umbrel Node?

Follow these steps:

  1. Log in to your node using SSH. Usually this means opening a terminal and typing ssh -t umbrel@umbrel.local. The user is umbrel. Default password is moneyprintergobrrr for older versions of Umbrel. New versions use the dashboard passord. When typing your password you usually see nothing (for safety).

  2. (Optional) change your default password by typing passwd

  3. Open the config file sudo nano umbrel/app-data/lightning/data/lnd/lnd.conf . lnd is small for LND, there are no i’s. It will ask you again for your password (same as before), and you will again not see you entering the password.

  4. You are now in the editor. Add alias=SOMENAME. This must be added to the first paragraph. Somewhere below the block [Application Options], not in a different block.

  5. (Optional) set color=#ff0000 or any other hex color, on a new line, just below alias. find a nice color.

  6. You will see the commands you can give at the bottom. The caret ^ means CTRL button. ^X is eXit, so use CTRL-X to exit the file. Confirm you want to save the buffer using Y. Press enter for file name (don’t change).

  7. After you have exited the editor, type cat umbrel/app-data/lightning/data/lnd/lnd/lnd.conf to look at the content of the file.

  8. Then restart your Umbrel node. You can do this properly from the Umbrel web interface (Settings, Restart)

  9. IF you have public channels, it will take (max) 2 days for the new node to become visible on

  10. If you have RTL installed you should see the new node name after a restart of RTL, or after logging in again. A node clean restart (using the web interface) should also restart RTL.

If your terminal freezes you may have pressed CTRL-S. Unfreeze by CTRL-Q.

Have fun :slight_smile:


Thanks! I have tried this before but I get an error saying POSSIBLE DNS SPOOFING DETECTED!

Any advise as to what this is?

I was able to figure it out! Had to delete the host file

THANK YOU so much! Worked perfect to me.

Perfect instructions. Thank you very much!

Thanks, sounds fun. Is this sort of like a vanity plate for your car? What are the cons to creating an alias? Thanks!

1 Like

Thank you - is the alias persistent across Umbrel updates?

Yes, since the latest Umbrel version lnd.conf is not overwritten anymore.


Done like you described, but now my btc wallet and lightning wallet wont show up! What did i wrong?:sweat_smile:

Check carefully that your node name is not to long (32 characters) and that there are not extra spaces. After you applied changes, just restart LND using the following command:

docker-compose restart lnd

1 Like

The name is not to long it’s: Buent09
i also did change the color


did it like shown here

do i have to tipe it under feeurl, or is this not relevant?

cd to your umbrel directory first!

cd ~/umbrel
docker-compose restart lnd

1 Like

ok thanks, now it’s restarting

i think this didn’t worked, restarted it 2 times, any ideas?

Restore your backup of lnd.conf and restart LND again, to see if it works without your changes!

now it worked, thanks for your help! :orange_heart::pray:

So I was able to set the alias following the above instrcutions. But how do you set an alias that includes a blank space or a symbol? Could someone please share an instruction on how to set the following example?

Ride the Lightning :zap:

Hi, I made the changes and everything seemed to go well, but now I’m getting an error on RTL after restarting. I’ve added alias on first line (it includes lowercase and uppercase and an underscore instead of space) and changed color.

Any idea on how to fix this?

how to restore lnd.conf ?