How long does closing a Lightning Channel take?


I tried to close a channel yesterday and it’s still in “closing” status. Normally channels close very quickly for me, but not this one. I think the other node is unresponsive or something, it was constantly going offline and online, multiple times per day.

How long can I expect my funds to be locked in this channel, before it closes?

Enter using SSH into your node.

Then run this command to check pending channels:

~/umbrel/bin/lncli pendingchannels

Look in the array “waiting_close_channels” and identify your pending channel with a string like


Also you can see when the funds will be released checking the “maturity_height”

“waiting_close_channels: [ …“maturity_height”: 700998,”

That means you will have to wait until that block 700998 is mined and your funds will be released. So just wait.

If you are very imaptient, then you can force close that channel. Run this command:

~/umbrel/bin/lncli closechannel --force 851ddc0900b775ff4afbd12ed4c8c003456eaea862ba96664344b06a04eec7c5 1

Again you can run the command to see the maturity:

~/umbrel/bin/lncli pendingchannels

and you will see the new “maturity_height” block number.


I really appreciate this thorough explanation, thank you!

1 Like

edit: nevermind

1 Like

I don’t see “maturity_height”…

1 Like

Did you ever get this fixed? I have the same problem. Every topic I can find about it remains unsolved? It’s like it’s being ignored.

1 Like

hi, the solution is good thanks

Hi, exact same problem

Tried to force close a channel following the exact instructions and commands mentioned here, but nothing happen, the channel stay in “waiting close” mode instead of “force closing” mode

Hello! I had a similar issue a while ago. Try looking here, and see if that helps.

Thanks for your answer Orville, but I have no skills in command line (so maybe I doing this wrong but I don’t think so) and when I try force closing this channel it doesn’t work, it says that the “channel is already in the process of being forced close”, but it’s not the case. The channel is still in “waiting close”. I have 2.5M sats to get back so it worries me a bit

The two nodes are mine, and the problem came (I believe) from the fact that I tried to restart the two node at the same time (by mistake), triggering a strange channel close from one of the 2 nodes. Now I’m stuck and unable to publish a correct signed transaction in the mempool. Also it’s a private channel, don’t know if it change anything.

The syntax of the lncli command looks fine, yes. Do you get the same result if you download the app lnshell from the Umbrel appstore and run the lncli command directly from the lnshell command line prompt?