Fresh install isn't findable on my network, and can't login via terminal either

I ran through all the instructions for installing Umbrel on a Raspberry Pi 4. I turned off my VPN.

The primary issue is I can’t get to umbrel.local. I ran Angry IP scanner to see which IP address Umbrel might be on but none of the accessible addresses worked.

I reflashed and tried again. Same issue.

I figured maybe the machine wasn’t booting up properly or maybe I did something wrong so I booted it up (without ethernet) while plugged into a screen and a keyboard.

I can confirm that it boots without errors.

However, my keyboard isn’t recognized so I can’t login, type anything, press “Enter”, etc. So I’m not sure how to run commands to further debug this.

After this point I wanted to check that the keyboard connection was good. And I can confirm that the keyboard works if I swap out the SD card with one that has the Raspberry Pi OS (lite).

Here are some related issues I’ve already looked at:

can you log into your router and verify that the unit is receiving an Ip address.

Usually your router will have an IP address of or something along those lines.

And then look for all connected devices.

Agree with @my_bitcoin, as you can see the Pi does start up Umbrel, so I believe it’s just going to be an issue of finding the IP for your node.

Here’s some further recommendations. Let us know how that goes :slight_smile:

The issue was that the device wasn’t getting an IP address. I added a wpa_supplicant.conf

This allowed my router to provide the device an IP address and I could access umbrel.local in the browser.

However, I was curious why ethernet wasn’t working because lacking ethernet would limit what I could do with Umbrel. I connected the same ethernet cable to my laptop and turned off wifi so I can confirm the cable and connection to the my network switch is fine.

It’s looking like the ethernet port on my raspberry pi isn’t working. I haven’t checked by using a stock raspberry pi image and I don’t have another raspberry pi 4 to check against. In any case, it’s working for now.

1 Like

oof you may want to get that checked out rather quick and replace the pi while its under warranty.

Im not certain right now as Im on some pain medication but I seem to think the USB and Ethernet share a circuit on the pi.

This may end up poorly in the future

1 Like