Cannot connect to Umbrel!

Hello, total newbie here. I setup my Raspberry Pi 4 according to the Install steps. Waited 30 minutes, tried connecting to “umbrel.local” on my Safari browser and a blank page appears. So I downloaded Angry IP scanner, downloaded Java 17 ARM version, opened up Angry IP scanner, scanned from - using default settings. I went through all 11 IPs that are alive (blue icon) and copy pasted each of them into Safari and keep getting blank pagesl. It seems I cannot connect to Umbrel. I am stuck, please help :frowning:

I use PuTTY very easy.

login with IP address
uname = umbrel
pass = your umbrel password

Don’t try to disconnect your power source. Because it will destroy your data. For me I use the command “sudo shutdown -h now”

Thank you for the reply. Sorry I’m a total non-techie. I downloaded the PuTTY 64-bit ARM .msi for my M1 Macbook, unzipped it, but cannot run it (I have no idea how to use PuTTY). I’m also not sure what you mean by login with IP address, and I’ve never setup an umbrel password… Kindly dumb it down for me :sob:

Ok, I’m aware of your problem. But now I’m at work. Tonight I’m going to answer your questions in detail.

Hi phosej’ The first thing I will tell you is I’m not an umbrel expert. I’m an amateur too. But that’s not a problem hahaha. Now I know you use Mac. And it’s not difficult to use SSH. Can you use it?

  1. Start by opening your terminal. Then type the command “ssh umbrel@umbrel.local” enter (If not try using the ip address of your umbrel instead. (for example “ssh umbrel@”))
  2. “Are you sure you want to continue connecting (yes/no/[fingerprint])?” ans “yes
  3. umbrel@’s password:” Enter your umbrel.local login password. But you won’t see the password. Therefore, please be attentive.
  4. Now if you are not confident to go further. I recommend you to shut down your system with the command “sudo shutdown -h now” (option -h = poweroff system) To avoid the risk of data corruption.

Then you just wait for the new version to be updated. Then you can come back and run your node again. (I think this problem is caused by this version. I’ve been running Node for over a year. I’ve only recently encountered this.)

But if you want more fun. and interested in further study I recommend you to read and follow the steps in this link. How to set a static IP for your Umbrel server

And you can find more knowledge here Umbrel Troubleshooting Guide

Hi GridsDev, I really appreciate your support. I did your step 1 but typing in “ssh umbrel@umbrel.local” did not result in anything. However I isolated my umbrel’s IP address in my router config to be I checked How to set a static IP for your Umbrel server and it does seem to be a static IP, so shouldn’t be that problem.

So I typed “ssh umbrel@” as you instructed into my terminal, then a line appears: “ssh: connect to host port 22: Connection refused”

I thought maybe that meant the port 22 on my router was not open, so I went into port forwarding settings in my router and configured a manual SSH TCP/UDP port forwarding on public & private ports 20-22 for local IP I restarted my router for the changes to take effect and re-tried step 1 and still got the Connection refused message.

I am stuck again at this point :frowning: Should I try editing my Mac’s hosts file?

oh!! after inaccessible problem, You haven’t closed it yet? If so, I think the Raspberry may have overheated until it hangs. I think there is nothing better than disconnecting the power cable for now. After that you follow the steps again. This time I ask you to do additional steps to fix ip static too. Wish you good luck. Don’t worry, I promise to be by your side until you finish this problem.

If possible I suggest you write down your seed key umbrel on a piece of paper. In the last case, you may need it.

1 Like

GridsDev, just want to let you know, I finally solved the problem. I found this thread Can't ssh into my node and I used Rufus to re-flash my microSD card, re-installed RP4, and then I could easily connect. It was a Balena Etcher improperly flashing on Mac OS problem. I hope this will help more people who have the same problem as I did. I am so happy right now!

1 Like

yeb :blush: :blush: sure you can. I have now moved to an Intel NUC and I am using Docker running on Ubuntu 22.04 OS which is much faster than the Raspberry Pi 4B but now I am having trouble remote into the image repository hahaha.

The raspberry has been in short supply in my country making it more expensive in recent times so NUC was my solution. :yum:

1 Like