Didn't receive BTC

I recently started up my node. I went to send funds to myself but during the process, my internet crashed. The BTC left my exchange but I haven’t been able to recover the bitcoin. I’m very new to this so I’m not certain how to deal with it. I can see my transaction history on chain but for some reason, it never showed up.

did you send BTC to the wrong address?
if you are sending to the correct address, the node may not have finished synchronizing with the network.

Bitcoin is sent or its not. If you initiated the send via your exchange then having internet will no longer matter. You mentioned the coin sent so if you input the correct address then it resides in the wallet you sent it to. My guess is that you have not finished downloading the blockchain. Without the full chain there is no way for the wallet to verify the coin sitting at that address. Once it has the full chain then it can verify the coins and that they do indeed belong to that address.

I was wondering the same so I sent a little more and it went through. I sent them both in the same way how could the address have changed?

I have fully downloaded the block chain. How to a verify it went to the same addresss?

Did you ever used a block explorer? Like https://mempool.space or https://blockstream.info
Just pout your address in the search box and will find all your txs.
Why do you have a node if you do not start learning how to use Bitcoin?
In your Umbrel node you have also 2 block explorer apps: BTC RPC Explorer and mempool. Did you had the minimum curiosity to install them and see what are doing?

Please learn more before doing other unknown txs, here some resources:

1 Like

Yes I did look through both of those. every time I click receive on my button wallet the address changes is that normal? Both my transaction say different address.

What confuses me is i followed the exact same process and it worked the following time. So I don’t know what happened in the first attempt

Seems that you don’t know basic usage of Bitcoin wallets.
Yes, for privacy purposes, any wallet is generating a new address every time you click on “receive”/deposit.
You need to learn basics about Bitcoin and coin control.

Will do. Do you have a rough idea of what I did wrong? What would have blocked the transaction.

Do you know what the transaction ID is?

Where do I find that? Im assuming this is it [783292aa9b282e6c543bd3d64ade3bee2f9f787813c3cea2d4b350b8b58944a6]

2118 CONFIRMATIONS 0.24455804 BTC

Is that your transaction? if so it has sent without issue

No its this one bc1q5ghwkzjz8ak5fyfa4k4tg3kjq5utkm29f4vstu

Still confused on how BTC hasn’t arrived. Can my wallet address change? I sent more to the same place and it arrived

Of course it change. Is by design to be like that, for privacy. Your lack of basic knowledge can cost you a lot of money, take care and start learning basic usage of BTC wallets.
In the Guides section of this forum we’ve posted a list of resources to learn more.
Anyway you can start here

I’m aware that the invoice number changes. I’m confused by how putting my recovery phrase in has not allowed me to receive the Bitcoin I sent to the wallet under that phrase.
Instead of telling me I’m an amazing idiot how about helping.

I can’t help you with your own base education in this matter. All depends of your willing to read and learn.
I helped you by sending you to the right documentation, but I can’t put that information inside of your mind. Is just impossible.
Anyway, this is not an Umbrel matter per se, is a matter of how BTC wallets work.

Hey @Lachness11, did you get a resolution to this issue? Another way to reassure yourself that your coins are still in your wallet is to restore your wallet into another app, i find that Blixt Wallet can be used to recover Umbrel seed phrases. So, download Blixt Wallet, then input your 24-word seed phrase and press recover wallet. You will find that your coins have been there all along! What you can then do is send the coins back into your own address (new address of course generated by your same wallet) and you should be good to go! Hope this helps!

This worked! I thought all hope was lost so thank you so much!

1 Like