Connect Samurai Whirpool (running on Qubes OS) to Samurai server (Umbrel)

I have Umbrel running on Raspberry Pi, Bitcoin core fully synced, Lightning running, and Samurai server installed.

When I try to connect Whirpool GUI (running on Qubes OS, on the same network, connected to the same switch), I’m getting error:

Connection failed: Could not connect to CLI (may take a few seconds to start...)

I think there is something wrong with Tor/proxy. This Qubes VM (where I’m running Whirpool GUI) uses sys-whonix for networking which means everything goes through Tor. So I tried to remove the Tor proxy setting, but it didn’t help.

Any tips on how I can debug this?

Do I need to set API key?

Given that I’m doing this on local network, I think I don’t even need Tor. Is there any way to access Samurai server (on Umbrel) directly, without Tor?

I tried using on QubesVM without Tor, but also no luck.

I’m not familiar with Qubes, but can you try with the normal Tor proxy. Either you find the port of the proxy built in Qubes or you install the tor package.

If you want to try on local network, use http://umbrel.local:8898.

Did you figure this out @crowphale? I’m having the same problem

Not yet.