Bitcoin Node does not start

Hi everyone,

I cannot access my Bitcoin Node anymore. I do have access to umbrel, but when I start my Bitcoin Node it says starting forever:

Therefore my Lightning Node is also not starting and I do have some open channels.

Can someone please help me?

Thanks in advance!


Hey Denn, I managed to figure it out. If you have the same problem as me, do the following:

ssh into your node:
ssh umbrel@umbrel.local

then remove these two files (likely corrupted by bad shutdown), one command at a time:
sudo rm ./umbrel/app-data/bitcoin/data/bitcoin/settings.json
sudo rm ./umbrel/app-data/bitcoin/data/bitcoin/peers.dat

then reboot:
sudo reboot

Should be syncing again. :wink:


I have this same issue and the above did not fix the issue. When I entered the above commands it said that these files did not exist. I navigated to the file location and found that I had all the directories in the path ./umbrel/app-data/bitcoin/data/ from there I was missing bitcoin/settings and bitcoin/peers and any other files.

Additional background is I had some malware that was detected from malicious domains my Umbrel was trying to reach (not sure if these were just tor domains). so I formatted the SD and did a fresh install of the Umbrel app. Then rebooted the raspberry pi. Since then I’ve been able to access the menus, settings install and delete apps, but when I ssh into the Umbrel to get logs it says error no bitcoin service is running.

ERROR: No such service: bitcoin

I’ve rebooted and tried a number of different things from the troubleshooting guide. I’ve also checked the RAM in the settings gui and can see the bitcoin “app”/service is running and using about 243mb of memory.

1 Like

You solution worked! Thanks a lot for the detailed description.


Same issue. You fix?

Same issue here. I see the last few threads created in support is about this issue, perhaps it can be fixed with an update from Umbrel?

After entering the command it requests for password again, and once i enter that nothing happens


Anyway, i restarted the node and its now working even though it looked like the command didnt go trough. Only used the 1st command.

I had this same problem. I’m not technical and was about to wipe everything and start again from scratch (aghh!) and then found your post and followed your instructions and it’s fixed. Thank you!!

1 Like

Copied this and also fixed my node! Ive had it for over a year and never had problems upgrading so this was a shock and glad i found the answer here :slight_smile:

1 Like

I have the same issue - how do I ssh into my node to delete these files?

OK managed to get the SSH thing done and back up and running after deleting those files.


I had the same issue and your instructions worked for me as well. Thank you very much!

1 Like

Hello. I have the same problem.
BTC starting node.
Because the Umbrel Server was no longer starting, I had to rewrite the SDcard.
After rewriting, the server started, but the BTC node does not pass the start.
I deleted the settings.json and peers.dat files and restarted but the situation remained the same.
any other suggestions?
It is possible to synchronize but it shows starting.
How long should I wait for it to start before moving on to more radical actions.

1 Like

No… it doesnt work. It shows No such file or directory…

Beauty… works, thanx a lot!


I tried the above and it didn’t work for me.
Just to help out anyone else with the same problem here is what worked for me.
I simply followed the instructions in the troubleshooter posted on this great Umbrel help site and powered off my Raspberry Pi, reflashed the micro sd card , powered it up and it worked!!!

Thank you! Solved my issue as well!



it seems i have the same issue, my apps bitcoin and electrum server are stuck in “starting”. I have try to reboot, shutdown, etc without success.

So i try to connect in ssh like explain in this thread but the connection doesn’t want to start or close immediately

What can i do ?

Confirm. It worked for me

1 Like

Confirming this worked for me! Thank you!

1 Like

I just had the same issue and this solution fixed it. Thank you! This community is incredible.

1 Like