BTC Node, Lightning and Electrs all not working

I’m having widespread problems with my Umbrel server.

It’s been running almost flawlessly for over a year on a RPi.

A few weeks ago, presumably after the latest upgrade, the node stopped working with other wallet apps such as Bluewallet and Zeus.

Symptoms are as follows:
Bitcoin Node says “Synchronized” but shows no data, no block info, balance, etc.
Electrs stuck in “waiting for Bitcoin node to finish syncing”
Lightning Node stuck at loading, approximately 60 percent.

Logs are pasted in the link below:

What I’ve tried so far:
*Several restarts/shutdowns.
*Stopping and restarting scripts as described in Marcaday’s post here Electrs stuck - reading app logs (and identifying docker processes)
*Reflashing the Umbrel OS onto the microSD card

Any help is appreciated. Thank you.

1 Like

Hey @LVONM! Sorry that you’ve encountered this issue :confused:
It looks like the bitcoin app is constantly restarting let’s check the bitcoin logs to see what causes that !
You can get the bitcoin logs using :
sudo tail -n 100 ~/umbrel/app-data/bitcoin/data/bitcoin/debug.log

Hi Marcaday,
Thank you for the quick reply! Please see below!

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent permitted by applicable law.

Last login: Tue Sep 27 17:12:32 2022 from

umbrel@umbrel:~ $ sudo tail -n 100 ~/umbrel/app-data/bitcoin/data/ bitcoin/debug.log

[sudo] password for umbrel:

2022-09-27T17:28:06Z InitParameterInteraction: parameter interacti on: -proxy set -> setting -discover=0

2022-09-2717:28:06Z Assuming ancestors of block 00000000000000000

0052d314a259755ca6594468d6b12a067ea8f1f5a7091 have valid signatu res.

2022-09-27T17:28:06Z Setting MinimumChainWork=0000000000000000000


2022-09-27T17:28:06Z Using the ‘standard’ SHA256 implementation

2022-09-27T17:28:06Z Default data directory /data/.bitcoin

2022-09-27T17:28:06Z Using data directory /data/.bitcoin

2022-09-27T17:28:06Z Config file: /data/.bitcoin/bitcoin.conf (not found, skipping)

2022-09-27T17:28:06Z Command-line arg: bind=“”

2022-09-27T17:28:06Z Command-line arg: bind=“”

2022-09-27T17:28:06Z Command-line arg: blockfilterindex=“1”

2022-09-27T17:28:06Z Command-line arg: chain=“main”

2022-09-27T17:28:06Z Command-line arg: listen=""

2022-09-27T17:28:06Z Command-line arg: peerblockfilters=“1”

2022-09-27T17:28:06Z Command-line arg: peerbloomfilters=“1”

2022-09-27T17:28:06Z Command-line arg: port=“8333”

2022-09-2717:28:06Z Command-line arg: proxy="’

2022-09-27T17:28:06Z Command-line arg: rpcallowip='"

2022-09-27T17:28:06Z Command-line arg: rpcallowip=“”

2022-09-2717:28:06Z Command-line arg: rpcauth=****

2022-09-27T17:28:06Z Command-line arg: rpcbind=****

2022-09-27T17:28:06Z Command-line arg: rpcbind=****

2022-09-27T17:28:06Z Command-line arg: rpcport=“8332”

2022-09-27T17:28:06Z Command-line arg: rpcworkqueue=“128”

2022-09-27T17:28:06Z Command-line arg: tindex=“1”

2022-09-27T17:28:06Z Command-line arg:

zmapubhashblock="tcp: / /0. 0.


2022-09-27T17:28:06Z Command-line arg: zmqpubrawblock="tc:/ /0.0.0


2022-09-27T17:28:06Z Command-line arg: zmqpubrawt×="tc: / /


2022-09-27T17:28:06Z Command-line arg: zmgpubsequence="tc: //0.0.0


2022-09-27T17:28:06Z Using at most 125 automatic connections (1048

576 file descriptors available)

2022-09-2717:28:06Z Using 16 MiB out of 32/2 requested for signat ure cache, able to store 524288 elements

2022-09-27T17:28:06Z Using 16 MiB out of 32/2 requested for script execution cache, able to store 524288 elements

2022-09-2717:28:06Z Script verification uses 3 additional threads
2022-09-27T17:28:06Z scheduler thread start

2022-09-27T17:28:06Z HTTP: creating work queue of depth 128

2022-09-27T17:28:06Z Using random cookie authentication.

2022-09-27T17:28:06Z Generated RPC authentication cookie /data/.bi tcoin/.cookie

2022-09-27T17:28:06Z Using rpcauth authentication.

2022-09-27T17:28:06Z HTTP: starting 4 worker threads

2022-09-27T17:28:06Z Using wallet directory /data/.bitcoin

2022-09-27T17:28:06Z init message: Verifying wallet (s)…

2022-09-27T17:28:06Z Using /16 prefix for IP bucketing

2022-09-27T17:28:06Z init message: Loading P2P addresses…

2022-09-27T17:28:07Z Error: Invalid or corrupt peers.dat (Checksum mismatch, data corrupted). If you believe this is a bug, please r eport it to As a workar ound, you can move the file ("/data/.bitcoin/peers.dat") out of th e way (rename, move, or delete) to have a new one created on the n ext start.

2022-09-2717:28:07Z Shutdown: In progress

2022-09-27T17:28:07Z scheduler thread exit

2022-09-27T17:28:07Z Shutdown: done

Alright ! It looks like there’s something wrong with the peers.dat file causing bitcoin to restart,
You can erase the corrupted peers.dat file using:
sudo rm ~/umbrel/app-data/bitcoin/data/bitcoin/peers.dat
The Bitcoin app will automatically recreate a valid peers.dat file and it should solve your issue :crossed_fingers:

Hi Marcaday, It looks like your procedure is working. Bitcoin Node is 100 percent synchronized and Electrs is not far behind. I can also see balances and channel information in the Lightning Node app.

Again, I really appreciate your help! Take care.

1 Like

Hi Marcaday,

I have this same issue. Except I use a Windows computer and I am currently abroad.

Is there a recommended way to erase the corrupted peers.dat file by ssh’ing in remotely to my umbrel overseas? Would I use Windows Powershell?

I do have a family member who is on the same modem/router as the umbrel. What commands would I get them to type into Windows Powershell to delete the corrupted peers.dat file?

Thanks in advance!

Hi VillatraxETH,

If you can access your local network via VPN (Tailscale might work too although I can’t confirm) then you should have no problem using an SSH client to log into your Umbrel remotely.

You should have no problem using Powershell or alternatively you can download PuTTY.

See the second item in this guide and note that if you use Poweshell, the command to login into your Umbrel is slightly different than conventional SSH clients such as Putty or ones built into Unix/Linux systems.

After a successful login then all you should have to type to delete the peers.dat file is

sudo rm ~/umbrel/app-data/bitcoin/data/bitcoin/peers.dat

Followed by the password again.

The general advice is to wait about 24 hours. My Umbrel was back in operation within far less time but YMMV.


Thanks for your response.

My brother (who is on the same local network as the Umbrel) used Windows Powershell, and started with the following command:

ssh umbrel@umbrel.local

That then gave an authenticity warning, which we then typed in:


We then were prompted for the password which we entered.

We used:

sudo rm ~/umbrel/app-data/bitcoin/data/bitcoin/peers.dat

Then we were prompted for the password again, which we entered and were then prompted for another command.

BTC blockchain resyncing:

Thanks so much for your help!

Hello Marcaday

It looks like i have a similar problem,

The node is stuck at this percentage, i tried to reboot, i tried the command you give but it doesn’t work.
Could you help me please.

Correction, the node is not stuck but he doesn’t sync anymore.