Wallet not connecting

Android Electrum wallet, new Orbot installed and Tor enabled, VPN mode enabled, big onion running, Auto-connect off, Server setting correct.

Electrum status shows several connections being made, but not to server. Server is running fine. Bitcoin Core is fully synced, and has been running for days.
I can use Tor Browser no problem. Orbot log shows a long list of exits tried and failed.

I’ve been thru the Forum, and done the traditional Googling. YouTube mentions a proxy node that is not shown in my instructions. Isn’t that for using Electrum thru Tor browser? Could there be a conflict between the two? Is Orbot even necessary?

It’s all about Orbot that is trying to connect.
Test with electrum on desktop, running the Tor service (not browser) and check your connection to your node. Optional you can check tor logs in your node too.

I suggest:

  • force close electrum on android
  • open orbot add electrum app in vpn apps
  • start Tor and WAIT until is 100% bootstrapped
  • only after that start electrum app

I would like to test Electrum + Tor service from my Manjaro Linux desktop as you suggest, but Tor service runs into a permission problem. Can Electrum use the Tor browser as a proxy instead? I see six year old instructions at https://tor.stackexchange.com/questions/6939/configure-tor-as-proxy

For my Android that I started with:
force closed electrum
open orbot, shows as only VPN mode app
started Tor, 100% bootstrapped, done

Funny, it used to do this:
started electrum app, connections float between 6 and 9, shows (connecting…)
Orbot log shows long list of “[scrubbed] using exit …”
Yes, it’s not connecting. The log says “NOTICE: Tried for 125 seconds to get a connection to: SOCKS 9050|HTTP 8118”.

Now it doesn’t even do that, the Orbot log ends at Bootstrapped 100% done, no connections are made.

NO. As you see in Umbrel connect wallet section- it is indicated: you have to use Tor service, NOT Tor browser. service and browser are two different things, don’t get confused.

SOLVED: It was a bad server address. The Server edit line in Electrum does not give an accurate view of the actual address. Plus there is no reality check of the address that is there.

Not an Umbrel problem. Sorry!

Wallet section does say to use Tor service, but you answered my question if Tor browser could substitute. Thanks.