Can no longer access my node with wallets through TOR

I’ve had electrum and set up with my node for many months and it has worked flawlessly. I would see the little blue light at the bottom right. However, now it’s just red and doesn’t connect. Tor is running on my system, as per the instructions in the Umbrel software.

I also can’t connect to it with sparrow, zap or any other wallet.

The node itself seems to be working fine, I just can’t connect to it with external wallets through tor.

I’m not exactly sure when it has stopped working. I’ve changed nothing.

Any ideas on how to troubleshoot this?

Maybe is not Tor but electrs.
Those external wallets are connecting through onion address, but what they really use is electrum server from your node.
You could try a restart of the node and/or check the electrs logs.
SSH into node

cd umbrel
docker-compose logs electrs

See if electrs is up to date with indexing blocks.

I have just restarted the node, and I just ran the electrs command you gave me, it looks like it is up to date and has the latest block. Still not able to connect.

Looks like it is working now :+1:

yeah, with electrs you need to have a bit more patience, the results are not immediately.