Unable to access Umbrel.local

Hello Umbrel Support Community,

I have setup my node but remain unable to access http://umbrel.local. I have followed all the various troubleshooting steps incl. using AngryIP, restarting devices etc. but still no success.
When I open it up via SSH, I was able to login, but I would like to use the actual interface and finish my setup. Could someone assist?

Set the context, including for example the following details:

  • On what device / OS you are running Umbrel (Raspberry Pi, Ubuntu Desktop/Laptop) - Rasberry Pi
  • How is your Umbrel connected to the Internet (Ethernet, WiFi) - Ethernet
  • What type of drive you are using (HDD, SSD) - SSD

Thank you!

1 Like

I suggest to take a look here in Umbrel FAQs and try to set a fix local IP to your node first.
Then in your PC from where you access it, try with the IP. If it works, you can add in your hosts file the IP - node.local entry.

Hello DarthCoin,

I have gone through the FAQs but it’s not clear to me how/where I go to setup a static IP. I used command prompt for the initial step, but where do I go to find / enter

sudo nano /etc/dhcpcd.conf ?

I am new to this, thank you for the help.

What OS are you using to access your node?
Windows, Mac, Linux ?

Open a terminal on your computer and enter ssh umbrel@umbrel.local , the password is is your personal user password. If it’s a fresh install (i.e. you haven’t set your password yet), or if you re-flashed Umbrel OS, then the default password is moneyprintergobrrr .

From there follow the instructions for changing the IP of the node.

Configure the static IP address for the Pi, the gateway path and a DNS server.
The configuration for the DHCP client (Pi) is located in the /etc/dhcpcd.conf file:

sudo nano /etc/dhcpcd.conf

The following snippet is an example of a sample configuration. Change the value of static routers and static domain_name_servers to the IP of your router (default gateway) from step 1. Be aware of giving the Raspberry Pi an address which is OUTSIDE the range of addresses which are assigned by the DHCP server. You can get this range by looking under the router configurations page and checking for the range of the DHCP addresses. This means, that if the DHCP range goes from to you’re good to go with the IP for your Raspberry Pi.Add the following to the /etc/dhcpcd.conf file:

# Configuration static IP address (CHANGE THE VALUES TO FIT FOR YOUR NETWORK)
interface eth0
static ip_address=
static routers=
static domain_name_servers=

Restart networking system
sudo /etc/init.d/networking restart

Optional steps: edit hosts file in your computer. Add the following line:
192.168.x.x umbrel.local
Replace “192.168.x.x” with your local IP of your node

For Mac - Tutorial how to edit hosts file
For Windows - Tutorial how to edit hosts file

Restart your computer to take the changes.
Done, from now on if you type in your browser umbrel.local will always go to that IP.
Remember this procedure is to access your node from your home LAN, not from outside of your LAN.
From outside, you should always use the Tor onion address of your node.


Hi MissBitcoin, I was experiencing the same issue as you and found the best place to start suggested to me from the Umbrel Telegram community forum http://community.umbrel.com/ was to run the below command when you can get SSH access. The debug information will tell you, once finished, at the bottom what the issue might be.

~/umbrel/scripts/debug --upload

This command came from this Troubleshooting guide

The debugging script identified a problem with connecting to the external SDD, so I replaced the cable and restarted the PI and then could access umbrel.local and finished the setup.

Hi MissBitcoin, The steps that DarthCoin suggested here were very helpful to me. How did you go?

Posted my full story to Support and Troubleshooting, but short story is had a little trouble upon setup with umbrel.local but when I manually typed in the IP address to which the Pi is hardwired, it worked and I fully setup my umbrel. Got to about 50% today, last time I was able to check, but somewhere around noon I wasn’t able to access from either my phone or desktop. Tried everything I know regarding the router setup, and now tried opening up SSH, but to no avail. I get the message “Operation timed out”. Should I restart the router…or the Pi…??

You seem to be very knowledgable and helpful on here so thought I’d try directly. Thanks!

Hello everyone,

I have my new BTC node and lightning network up and running but when I went to my Onion address given to me so I can access my node sign in page it gave me this…

Can anyone help with this?
Thanks in advance.

Did you get this solved?
Ihave the same problem