Complete noob - Error: System service failed

Error: System service failed
Something went wrong when starting Umbrel.

I have spent most of my day trying to get something other than this when I go to http://umbrel/, but I’m stuck. When I go to https://umbrel, I get: # This site can’t be reached umbrel refused to connect.

I have downloaded umbrel-os-v0.4.6, and flashed it first to a 128GB card, then to a 64GB card. I have tried with two differend Pi’s, one Pi4 4GB, and one Pi4 8GB.

I have tried to disable VPN.
I have tried to connect via cable, and via Wifi (adding file wpa_supplicant.conf.
I have tried to add static IP SSH (which works), following DarthCoin’s guide.
I have tried connecting using Brave, Tor/Onion, and even installed Chrome again :frowning:

I suspect it MIGHT be because I’m using a DECO M5 mesh network, but I have tried connecting both to the router directly and to one of the nodes - SSH only works when I connect to a node. Since SSH is working, I’d assume there’s something else that is the problem anyway, but perhaps someone has experience with issues connecting to mesh networks?

Anyone have any idea what else to try here?

1 Like

It is umbrel.local not just umbrel. and is http not https.
So full address to access it locally is http://umbrel.local or http://nodeIP (put the IP here)

Please read the getting started guide with Umbrel

Thank you Darthcoin, but I get the same result. Sorry, forgot to mention that I’ve tried both of those addresses (with/without .local) and with IP directly. Since I’m on Windows, it says try without .local, but I’ve tried both. I’ll take a look at the getting started-link. Thanks. :slight_smile:

I tried that too. Made no difference, unfortunately.



Why are you using on local network a mesh network instead of just a simple LAN access?
Connect Umbrel node machine to your router.
Connect your regular PC to your router
Go to your PC open browser and type: umbrel.local or IP

I have mesh to strengthen signal in home with floors and walls. Normal router don’t give strong enough signal to all rooms (and son is pro gamer, so need good ping). PC is connected to wifi, Umbrel node to router/mesh via cable.

What confuses me, is that it says “Something went wrong when starting Umbrel.”

1 Like

So - finally, it’s up and running! :slight_smile: I used Knoppix to delete the partition on the SSD. Then, downloaded latest Umbrel-version, flashed card, and started over.
Amazing feeling when startup screen appeared without errors/warnings! :slight_smile:
Thanks for help and suggestions along the way, @DarthCoin.

1 Like

I also have been struggling with a mesh network. I rent and the house has a Google nest which I believe is causing some issues. @naggiz was there anything related to the mesh network? Or was it really just the partition?

Many thanks!

I believe the solution (in my case) was just to delete partition and do a clean install. Can’t see anything in the changelog (from 0.4.6 to 0.4.8 which indicates that new Umbrel version should handle mesh better.

You connect via cable? To the router itself, or to a network point?

What about computer? I saw a guy on Twitter who solved connection issue by connecting to 2.4GHz wifi instead of 5GHz

can you make a video on youtube? I have no idea how to use Knoppix and “delete the partion of the SSD” I am not this technically savvy