Umbrel v0.3.11 is out with latest apps, hardware failure detection, and low RAM alerts

[Update: Umbrel v0.3.12 was just released which fixes a bug in v0.3.11 that made Umbrel inaccessible over Tor]

Umbrel v0.3.11 is out with the latest versions of Specter Desktop, ThunderHub, Sphinx Relay, Ride The Lightning, and LNbits in the Umbrel App Store, hardware failure detection, low RAM alerts, and stability improvements. Just login to your Umbrel to update! :rocket:

Until now if there was ever an issue with your hardware, your Umbrel would simply become inaccessible in a web browser. With this new update, you’ll now get clear actionable insights if something goes wrong, like this:

Also new — if you’re running multiple apps and your Umbrel exceeds 90% RAM usage, you’ll now get a notification in your dashboard:


Updated. No problems. Thank you!

2 Likes download takes you to v0.3.10…where to download latest v0.3.11?

Here’s the v0.3.11 OS image, but if you’re already running Umbrel you can just install the update in one-click from the dashboard.

1 Like

the update is running on raspberry 4 // 8gbram :slight_smile:


1 Like

Great update - smooth as always.

For those of you using Sphinx on iOS - you may have to delete the app, re-install and restore if you have any issues after the relay update. It is being worked on so just in case…

1 Like

Is there a changelog for each update somewhere?


Clicking “Check for Update” didn’t recognize v0.3.10 as old, so I did it manually.
Now it shows: Client: 0.3.11-build-6f956cb is this accurate?

Works like a charm :ok_hand:

1 Like

Awesome! It worked smoothly. Thank you so much! :star_struck:

1 Like

Smooth update to 3.11 in a few minutes - Lightning channels reconected a few minutes after.

1 Like

Because we use atomic git commits, the commit history also acts as a nice and clean changelog. For eg. here’s the changelog from v0.3.10 to v0.3.11.


No worries, you should be fine! The “build” tag appears if you do a manual update and there’s no difference in the actual software itself.

1 Like

Is there a new update v0.3.12?

How long does everyone’s nose take to update? Every time I update it always seems to stop on the “removing old containers” screen

today I finish synchronizing the node, and I get this low ram warning.

I think link to raspberry 4G they have to change it to 8gb

I bought the raspberry 4gb and I am just going to install applications and I already have the low ram warning :confused:

Hi I just updated to v0.3.13 without issue, I then followed the procedure to rename my node alias which I do after each update. I’m pretty sure I did it correctly but maybe not as now my node will not fully boot. It just sits there saying ‘Starting Umbrel’ Is this a matter of start from scratch and restore? or is there a workaround?
Edit: I can still SSH into my Umbrel, it looks like somehow I wiped the lnd.conf file as it’s now just blank. I don’t have a copy so I assume reinstall from scratch?

You could try use the lnd.conf file on github?

@Reach Thank you for the link, much appreciated. I don’t know what happened but I came back to try this today only to find my node booted up and working fine :man_shrugging: The lnd.conf file is fine and has the alias I added just before it appeared to have been broken.
Maybe I did it too quickly after the update and there was still something happening in the background or something like that? Either way I’m back up and running. But this has made me want to get a better grip on recovery incase my node does fall over. Thanks again for the reply