Issues after Latest Update to v0.3.13

  • On what device / OS you are running Umbrel Raspberry Pi
  • How is your Umbrel connected to the Internet Ethernet
  • What type of drive you are using SSD via USB

After the last update v0.3.13 installed on 6/22 I am having intermittent connectivity issues. My payment channels connect on boot up but after some time they disconnect. I can access the web app upon boot but same as the payment channels the web app cannot be connected to after some time. The really strange part is if i go to umbrel.local from my phone the web app connects, but not from my laptop in the same WiFi network. I am able to go to settings an reboot the Umbrel, and for a short time everything works again.

Also, it is not found with Angry IP Scanner when the web app is not accessible from my laptop.

I will add logs later today.

Other issues that may be related, automatic channel backups fail while I am unable to connect via my laptop. I know this because when I connect through my phone I see error on the last backup attempt.

When I try to SSH in to the Pi while my laptop cannot connect to the web app, it will not connect, but my phone can still load the web app.

I should also add that I have been up and running for about a month without any issues. Which is why I think it has to do with the update.

I am not sure what to do. Is anyone else having any of these issues? Thanks!!


Read this and add more details to your post accordingly so people can help more efficiently: How to efficiently report an issue

1 Like

OK I got home from work, rebooted my Umbrel, SSH’d in, and ran this command:

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.3.13

The forced update ran fine, I will keep this thread posted as to if this problem is resolved or persists.

@JDeesy I am in the same boat, I have tried twice to reflash the sd card, both times the node has become unavailable after a maximum of 2 hours.

I just tried accessing the node from my phone over ssh and the web app and I can connect to it! This is very strange

1 Like

Try the command in my last comment. I have been back up for 2 hours so far. I have been able to access my node through Zap from outside my house and access the web app via browsers in my WiFi as well as via tor browser since the forced update via SSH. If it fails at some point I will report back.

1 Like

Thanks for the suggestion @JDeesy, I had tried that earlier today and it worked for about 2 hours.
I will definitely give it another go.

After running my node without a single issue for the last month I have the exact same problems as you after this latest update. It’s very odd how I can still access my node using my iphone, but not my macbook?

1 Like

Ok I’ve just tried reinstalling the update using this method, at the moment it’s working perfectly again.
Will report back later today

Same problem for me.

Works like a charm since 2 months, Umbrel out this morning (no SSH too).

Unplug to reboot, connect, SSH with your line code.

Reboot OK.

I’m waiting 1 or 2 days to give you a feedback.


1 Like

Add me to the list of people with this issue, I thought it was because I changed my alias after update and made a mistake, but I’ve now flashed the SSD a few times with 0.3.12, 0.3.10, etc, and nothing has worked.

Trying the above command in terminal… At the very least, it got things back up and running (I was getting 0 docker containers before) in a way that refreshing didn’t seem to.

I’ll update in a few hours as to whether or not it persists.

FYI, for those of you who want to be alerted about your node going down, I discovered a kick-ass Telegram Bot that will monitor it for you for free w/ a 1 hour delay:

Set up monitoring by saying /start to @lightningwatchbot. 

If you want "instant" notifications for 7 days, send /referral 1570350100 once you're set up (I'll also get 7 free days :) )


Same issue here.
After the last update (v.0.3.13) lot’s of connectivity issues and with each blackout starts validating blocks like from 2 days ago.

Still up, 2 hours later, after running the command above.
I haven’t changed the node name, though. I’ll do that, and report back again.

Last night my node went down again with the same issue. I decided that I would try force updating via SSH to a pervious version to see if that would work.

I ran:

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.3.10

I have been back up for 12 hours, the longest I have been up since I tried the 0.3.13 update. Not out of the woods yet, but seems to be working now. I get the green bar that says there is an update available, but I just close that out, to keep from my neurotic updating of my devices.

thanks for letting me know @JDeesy. What seems to be working for me has been to set the node up to use a Static IP address.

I needed to reboot the node for the changes to effect.

Have you looked into doing that?

and yes I think v0.3.10 or v0.3.11 was the last time the node was ran without any issues for me

Updating that while I was online for 2 hours after the force-update (maybe not enough time to actually test, though), after updating the Alias and restarting, I went down within an hour.

So, it might be something to do with the alias. Are you guys doing custom aliases? Or just me?

EDIT/IDEA: I am starting to suspect that this might have something to do with IPV6… how many of you are running IPV6 who are having the problem?

1 Like

@The_Lorax how can I verify if I am using ipv6?

Log in to the command line, run “ifconfig” and then see if there’s an IPV6 address next to eth0 assuming you’re connected by wire

yes there seems to be an entry:
inet6 fe80::217:1b52:7ha:va12 prefixlen 64 scopeid 0x20

Yesterday I setup the node to use a static IP address, but I imagine that the ipv6 address would still be dynamic?


interface eth0
static ip_address=
static routers=
static domain_name_servers=

So that static IP didn’t solve your issue?

I followed these instructions to DISABLE IPV6, and I’m back online. I’m going to see if it holds:

Feel free to try it on your own, as well. Please note that I’m not a programmer or system admin, and most of the changes I make end up doing more harm than good… so follow my lead at your own peril. But, I’ll report back later tonight probably and let you know if I stayed online as a result.

My theory is that IPv6 is causing issues and switching back and forth (see the guy in the post above, he had connection issues, too), and something about 0.3.13 is causing it to switch back and forth to IPV6… So disabling it might create more stability (alongside static IP of course).

1 Like