Umbrel stuck in sync state still after reinstalling os and trying other troubleshooting

I do not know when this started because one day I assumed the UI was just loading slow then i realized a few days later when I tried it was an OS issue. I can still ssh into my umbrel. I tried all of the suggestions for this symptom except reinstalling from seed because it is a last resort. The SSH keypair changed on my device after reinstalling the OS idk if that is normal but the password stayed the same. Either way I need to know if there is another troubleshooting step that is not listed that I could try before I try to reinstall from seed. The UI is just stuck on sync for bitcoin core and lightning and everything else but I can log in. It was happening pre and post upgrade.

Hey @PumbrelWumbrel, sorry to hear about the stall (actually had a similar issue myself recently), curious if you’re able to get some logs for us to look at - curious to see whether the sync is actually happening on the backend (in which case you might just need to wait).

Probably could use both the general debug logs, and also the bitcoin-specific logs:
docker-compose logs --tail=300 bitcoin

Here is my log file
Please let me know what to do.

@jonsyu please get back to me i fear all my channels have probably closed by now

Reading a guide from jonsyu and your logs, i would suggest sshing:

sudo systemctl stop umbrel-startup && sudo systemctl start umbrel-startup -reindex-chainstate

but i’m not shure if start will accept the option (-reindex-chainstate).
If it works, it may take many hours to reindex all blockchain

I also find this instructions to reindex blockchain:

Hey! Please SSH into the Pi and execute the following command to reindex the blockchain:

echo reindex=1 >> ~/umbrel/bitcoin/bitcoin.conf && sudo reboot

After it’s synced 100%, run this to stop it from reindexing on a future restart:

sed -i "s/reindex=1//g;" ~/umbrel/bitcoin/bitcoin.conf && sudo reboot

I am fine with waiting hours or days for reindex I would just like to get back online without re-seed, thank you for your reply I will attempt this soon and post results.

Hello again @LoboGuara, I attempted the first command and my umbrel is still in the same state it was in before. The UI is loading, it claims the bitcoin core is synchronized but the UI still says synchronizing and it doesnt allow me to operate any other parts of the system. It indicates that lightning is not operational. Bitcoin core may be synced but it is also unlikely because of the way the UI is behaving. Can you recommend any other solutions for me? @jonsyu please get back to me too if you can add anything. Otherwise I will just go through with the manual reinstall. I understand this is beta software, but this is the 2nd time I have had to recover my umbrel device and it is starting to put me off of this ecosystem a lot.

Hey, sorry for the delay - so, it does seem like there’s some corruption going on, though I also would’ve recommended just reindexing. Could you potentially generate the full logs for me to look at? You can just go to settings->troubleshoot->start, and it’ll let you download the logs and then you can just add them here as an attachment.

@PumbrelWumbrel , yes RPi is not reliable to be a pro server, I find there is unrealistic spectation on this. This week my Umbrel seemed fine, I did a shutdown, SSD got corrupted and coudn´t restart, I can’t imagine why. Statics? Linux bugs? USB 3 bad specifications? But we have no time or resources to do research. Loosing all service once every month, not easy to go on.

@jonsyu Hello, I will paste my log here. Please look over it as soon as possible thank you.umbrel-1642474628899-debug.log (39.0 KB)

@jonsyu any update?

Using HD?

Hey, it seems like your blockchain data got corrupted unfortunately, I think you might need to try reindexing. If you check out this guide by a community member, he has some steps under the section “Blockchain data is corrupted, how can I fix it?”


Several people said here low speed HDs won´t go syncronising blockchain. Change to a SSD as recommended. And even with SSD, be warned that is common bad USB cables or bad usb-to-sata adapters go corrupting data.