Bitcoin Core stuck at Synchronizing in 0.4.4

I’ve been running the prior Umbrel version, and it was syncing fine, but after the update to 0.4.4, syncing got stock for both Lightning Wallet & Bitcoin Core.

  1. Lightning Wallet - was due to a locked waller; I was able to unlock it manually by:
    ssh -t umbrel@umbrel.local
    The prompted password is your dashboard password.
    Then executing:
    cd ~/umbrel && docker-compose exec lnd /bin/bash
    lncli unlock

*Thanks @Lord_of_Waringham ( ref )

  1. But the Bitcoin Core is still stuck at syncing
  • seems like a Tor issue? It’s getting stuck & ‘giving up’?
    Have tried resolving or connecting to address ‘[scrubbed]’ at 3 different places. Giving up.
    tor | Oct 13 06:24:31.000 [notice] New control connection opened from
    ** nevermind, I see in others’ logs that it’s a standard thing*

Attempted solutions:

  • reflashed the SSD - no help
  • checked for undervoltage
    vcgencmd get_throttled
    it’s outputting ‘throttled=0x0’… so should be fine
  • I did some harsh restarts and power cut offs (before reading the guides :-/ ). Not sure if it compromised any of the hardware or anything; I’m having hard time to read the Dmesg logs - I’m setting up Umbrel for the first time, not sure how the log should look like normally, this one is very hard to comprehend to me; not sure if entirely bogus?

Thanks for help,

Debug Log:

1 Like

Recently, after some power outages - I was not even able to login through Umbrel GUI, the screen was getting stuck at flashing “login” button.

I’ve proceeded w/ downgrading to 0.4.1 via terminal

  • the login issue was solved
  • both of LN & Core still stuck at syncing, though

Next debug step

My Bitcoin Core also gets stuck when it reaches 100% synchronized. It downloads the latest block (mined 1 minute ago, let’s say) and then it does not get any new block for hours, until I reboot the server and it starts syncing again… until it gets stuck again and so on.

But I’m not sure whether my problem is somehow related to yours: