Umbrel reports SSD disconnected after hours of writing data to it

Hi - I just got a brand new Pi 4 Model B, and yesterday went straight to flashing Umbrel on an SD card. I purchased a brand new Crucial Crucial CT2000X8SSD9 2TB X8 Portable SSD (Up to 1050 MB/s, USB 3.2, USB-C, USB-A) for the BTC blockchain storage which is connected directly and powered via a USB 3.0 port of the Pi. I am managing it through a Win 10 Pro machine, using Firefox (latest) to get to the UI.

I set it all up fine and left the BTC sync operation running overnight. It had got to about 6% or so when I went to bed. In the morning there was an error saying the external SSD had been disconnected. After many attempts to restart Umbrel, checking the SSD was still functioning by connecting it to Win 10 Pro machine directly and viewing partition etc, Umbrel simply would not recognise that it was there. I had to resort to formatting the SSD via Windows and after trying exFAT and NTFS, only the latter worked.

I then did a 24 word restore and began downloading the blockchain again, which had to be started from scratch. It had been running all day today and last I looked was over 8%. Then I saw the error again saying the SSD had been disconnected, which it had not. And now I’m in the same situation where Umbrel doesn’t recognise that the drive is there at all.

Can anyone advise ?

So you have a hardware problem but you still insist in doing software reinstall, without fixing what is the real cause:

  • the USB cable
  • power adapter
  • SSD case
  • SSD itself

Also NEVER connect the SSD that is with a ext4 partition format to a windows OS. Windows will NOT read that partition and accidentally you could even change the format and broke your node data.
If you really want to read the content, connect it to a linux OS.
The only time you could connect it to a windows OS (and you don’t have a linux) is when you want to delete the partition for a reinstall. Do not create a new partition in windows, just delete it, leave the disk blank. The UmbrelOS installation will format it in the right ext4 format.

Well, thanks for replying DarthCoin but maybe chill out with the patronisig tone. Because I am new to Umbrel and I don’t appear to have any software diagnostic options once I get to the point where the UmbrelOS doesn’t see the SSD - that’s precisely why I resorted to testing the SSD back in Windows to see if there was a hardware issue, where there doesn’t appear to be. I eventually reformatted the SSD to test that it was fully working. Ininitally I did in fact try just deleting the partiton without reformatting in Windows to allow Umbrel to reformat it and it was only after Umbrel continured to fail to detect the drive that I went back and reformatted it in Windows, after which (once NTFS was used) Umbrel did recognise it and then do it’s own formatting again. The SSD is brand new and built into it’s case, it’s not one I’ve added to an enclosure. The drive and cable are fine, it worked initially with the Pi and it works in Windows. It worked subsquently again, as described, with the Pi. I have tested it with all four USB ports on the Pi. The power adapter is the one that came with the Pi.

I don’t really care if you do not like my tone. This is me and how I usually talk.
The tone is not important, important is what I am saying to you not how I say it.
Don’t be so snowflake.

You have to understand that a Pi is a low voltage device, if something is eating up too much all the external components will stop working and in special the USB SSD.
It really doesn’t matter is all components are working on another PC.
The weakest link is the USB cable, if this one fails, your node is gone.
Search and buy for another USB cable or even another SSD case (sometimes even these are failing).

But one thing is clear: if Umbrel page it says is a hardware failure it is clear where to look.