Gone offline randomly

So my Umbrel has been working away for 6 months or so, all recommended hardware, always online. Opened a lightning channel 2 weeks ago and had been using it to familiarise myself and using the BTCPay Server API for my Uni project.

Noticed that it wasn’t reachable yesterday, tried umbrel.local, tried an IP scan on my network, the usual. Both LEDs on the RPi board are on constant (not sure if that’s normal) and so are the two on the Ethernet port (usually the green one flashes w/ activity I think).

I took the SD card out and Windows wanted to format it, not sure if that’s normal, would have thought it would have been able to read it as is? Also plugged the SSD into windows machine and it didn’t come up in file explorer at all?

Does it sound like one some piece of hardware has broken?

Any help is much appreciated!

Windows won’t read Ext4 file system of Linux.
Avoid cutting power to Rasp Pi, that will corrupt files of SSD.
Attach a monitor to the HDMI output of Raspberry Pi and reboot it. Look at the messages if you see any error or failed process.
If using an old Umbrel version, reflash SD to version 1.4.7, its a good version.

1 Like

Just want to add that this was just the SD needing reflashed :blush: