WD BLUE 1TB 3D NAND SSD suddenly not detected by Raspberry Pi 4!

My Raspberry Pi 4 suddenly (!) does not detect my WD BLUE 1TB 3D NAND SATA SSD.


  • Raspberry Pi 4 Model B Rev 1.4

  • Umbrel (Version 0.4.9)

  • Flashed OS Version v0.2.15

  • Firmware (Oct 22 2020)

I have figured out to run automatic Issue finding tool over SSH (~/umbrel/scripts/debug --upload) and got the following feedback (only part shown below:
“You have either no external drive connected to your Raspberry Pi or the drive is not being detected.”

I have not been using Umbrel for a while . I have already shut down umbrel and have restarted multiple times. Have also unplugged SSD and tried another USB port. “Blue light” on SSD is not flashing anymore like in past.

Wanted to recover my umbrel wallet in Bluewallet but for some reasons it shows only a fraction of my funds. I recall that I have closed channels some weeks ago, but dont recall losing funds. Strange, but that is a separate issues. First need to get umbrel running again!

How do I find out what is broken (Raspberry Pi, SSD, Umbrel) and how do I fix it? How do i best approach this? Can someone look at my error logs? Shall I reflash Sim Card, buy new SSD…I am non technical…Please help. Its my daughters savings.

Bluewallet is only able to import on chain funds.

If you had funds locked up in open channels then those have to be closed. The funds will then be added to your on chain balance.

Ive been told a specific umbrel developer can do that for you but I don’t know who to ping.

1 Like

Thanks. Any Idea how to get my umbrel running again? See my problem statement above pls

Hey, there’s a few things that you can try - I’d start with reflashing the sim card first since that won’t hurt anything. Also, are you using the official raspberry pi power supply?


thank you for your answer!

Yes, I use the official raspberry power supply.

Is there a chance I lose my daughters funds/savings when I reflash my sim card? Never done that…

Thanks for helping… I am non technical !

As long as you have your seed phrase, your funds will be safe. Also, the sim card doesn’t really have anything too important on it, so no worries with reflashing.

I have flashed the sim card, I still get the error message:

Error: No external drive found
Please connect an external drive (at least 1TB) to a USB 3.0 port (blue color) on your Raspberry Pi and restart your Umbrel.

Is the next step to buy a new WD BLUE SATA SSD 1TB card ? Or can I somehow check the health of the card with a specific software

Try to open SSD in raspberian. If it dont open or if show issues, get a new usb3 to sata adapter case and a new usb 3 cable and go test the SSD. Both thoses parts also get broken, maybe more than the SSD itself.
Install Crystal Disk Info in windows and it will rate health SSD status (note in blue is nice disk).

Hey 21-Million, I heard you were still having issues with this - as LoboGuara mentioned, the next set of possible set of issues might be the connection from the external drive to the pi itself.

I would try the following, in this order:

  1. Recheck all the connections of the drive, try plugging it into one of the USB2.0 slots (the not blue ones) on the pi and see if that boots up again.
  2. If you have one, try using a different drive enclosure or USB cable to connect the drive to the pi, we’re trying to see if it’s the drive itself, or just the connection between the drive on and the pi.
  3. If that still doesn’t work, then we’re probably looking at formatting the drive, or replacing the drive entirely. Before you get that far though, I’d like to see some logs, could you follow these steps and paste it into something like 0bin.net? How to Generate Debugging Logs

All, Umbrel is running again. The cable and case for the SSD was the root cause. I have ordered a new one and everyting works. Strange!

Thank you to everyone supporting me on this. My daughter is very happy and says thank you too!

Glad that this community exists! A big thanks also to Luke!

1 Like