Umbrel only reads microSD storage and not ssd

I have the same problem as this thread (umbrelOS 1.0 reads only microsd storage - #39 by mayank), but I didn’t manage to solve that problem. I’m using a Raspberry Pi 4 with a microSD card to run UmbrelOS and a 1TB SSD for data storage. After reflashing the microSD card, I no longer have access to my old account. Upon starting, it prompts me to create a new account. Once logged in, I only see 20GB of storage, which appears to be just the microSD card, rather than the 1TB SSD.
Hardware doesn’t seem to be the issue, as I have replaced most of the components, yet the problem persists. While troubleshooting with SSH into Umbrel, I discovered that the SSD is connected but is in read-only mode. All attempts to switch it to read-write mode have been unsuccessful. Additionally, I have tried flashing different versions of UmbrelOS onto the microSD card, but the issue remains the same. Is there a solution to this problem or is it still something that has to be fixed?
Any assistance you can provide would be greatly appreciated.
Best regards

Sorry to hear about your issue here. While we investigate this, you can revert to 0.5.4 with this image here, found under the 0.5.4 release.

Thanks for getting back, can I just use the tar.gz file for booting? Or do I need a img file?

Tried the 0.5.4 version, this is what I get