Umbrel does not detect the connected SSD

Hey y’all, I tried setting up Umbrel on a Raspberry Pi5 yesterday and while I got the OS to boot and run, I only see the storage from my SD card as the available storage and Umbrel fails to detect the connected SSD.

I’ve read through the official troubleshooting guide. I’ve looked at the logs and I don’t see the logs that are mentioned within the External Hard Drive Connectivity Issue on Raspberry Pi section.

I’ve tried running df -H and lsblk and the drive does not show up in those commands either.

Other things I’ve tried are:

  1. Restarting Umbrel OS
  2. Rebooting the RPi5
  3. Re-flashing the SD card (saw this suggested on both Discord and these forums)
  4. Manually formatting the SSD to exFAT (saw this suggested on here)
  5. Tried 2 different cables and 2 different ports on the RPi5


  1. Raspberry Pi5 with 8 GB of RAM
  2. 1 TB WD Blue SA510 SATA SSD 2.5”/7mm Cased
  3. The recommended Orico hard drive enclosure
  4. A 128 GB MicroSD card from Sandisk

Note 1: I initially created this thread on Discord as I am more active on there but didn’t get a response (seems to be the general theme on there sadly) so I am reposting it here.

Note 2: I’ve seen several threads with people having the same issue. Some have responses from the community but not really from the team? It’d be great if someone from the team could help debug this.

Happy to provide any more information that is required.

1 Like


I’m having the exact same issue but on a Beelink Mini PC s12 Pro.

I’m struggling to find a solution. I do see the SSD in the BIOS setup, but there’s no way to make Umbrel recognise it.

If you finally solve it, would you be so kind to share?

I’ll do the same.

All the best

The same problem here. I have two HDDs with films connected to USB but umbrel doesn’t recognize them.
As a result I can’t add them to Plex either
I’m on version umbrelOS 1.2 Beta 1