Umbrel 0.4.11 is out with 4 new apps and bug fixes

Umbrel 0.4.11 is now out with 4 brand new apps in the Umbrel App Store — ItchySats (P2P Bitcoin derivatives trading), Lightning Shell (charge-lnd, lncli, lntop, rebalance-lnd, suez), Helipad (Podcasting 2.0), and SatSale (Bitcoin payment processor), updated apps, latest Electrum server, performance improvements, bug fixes, and more. :tada:

Trade Bitcoin derivates in a truly peer-2-peer manner with ItchySats, directly from your Umbrel. No accounts. No middlemen.

Supercharge your Lightning node management with powerful command-line tools brought to you by Lightning Shell.

View boosts and boost-a-gram messages coming to your Lightning node from your listeners on Podcasting 2.0 apps with Helipad.

Accept Bitcoin payments directly on your Umbrel with SatSale — a simple, lightweight, and self-hosted payment processor.

Twitter announcement:


I can not ssh my Umbrel node(connection refused), after I updated to 0.4.11.
ssh umbrel@umbrel.local

Upgrading has produced some weird results when installing Satsale. More exactly, it’s creating lightning invoices of 100 mil sats by itself to the bitcoin mainnet with 1 day expiration. NOT JOKING!

When removing/installing, same thing.

Has the code been audited?

Great work. Lightning Shell is awesome. I don’t have to pull the rebalance-lnd image manually anymore.

Thanks everyone.

I’m seeing the same issue with satsale creating 100 mil invoices.

Completed upgrade just now. All appears to be good over Tor, but accessing over the local network on umbrel.local seems to be broken. Shows a weird list of a bunch of possible conflicting errors instead of the actual login screen:

solved - this is a behaviour of chrome. refreshing fixes it. No access to umbrel.local after upgrading to 0.4.11


I clicked on “check for update” in settings and it still shows 0.4.10 as latest version. is there a slow rollout?

1 Like

Lightning Shell app jumbled…scrambled UI after login.


itchysats doesn’t have change password?

I really don’t understand how anyone could release an app without this ability. Let alone a trading app that you have funds on.


Problem with RTL and Mempool not starting after Umbrel Version 0.4.11 update, hope to fix soon

Had the same issue with mempool not starting. I did another upgrade using the command line and it started after that.

There was an SSH protocol update a while ago… The password is now the same as your umbrel.local log-in screen. There is no longer a default password.

1 Like

Yes, I used the log-in screen password. It says connection refused.

Node: HiFiBTC

On the Umbrel main screen I click on settings on the bottom left corner then click :recycle:CHECK FOR UPDATE and it tells me that my Umbrel is on the latest version 0.4.10 why isn’t it finding the new update?

Probably a UI glitch. Try updating from the command line. (Search for Umbrel Troubleshooting Guide)

What is username and password for the Lightning Shell app? I’ve tried all the usual suspects and no joy.

Ok I’ve answered my own question, by going back to the app store, and I found the login and password there. unfortunately when I login, I just get some multicolored hash that is unintelligeable. When I type in exit and try to close the window. I get a message that it is asking to confirm I want to leave, I type “y”, I type “yes” but no luck. It’s like a broke down hotel california!

Here is a screen capture.

2 days and no explanation or solution for the lightning shell bug?