Turn off the LEDs of the Raspberry Pi

Not everyone likes lights, so here’s the option to leave the Raspberry Pi completely in the dark, disabling the power, activity and ethernet LEDs.

Power off your Umbrel under Settings > Shutdown, and remove the SD card.

Then, put the SD card into your computer, you should see it show up in your file manager with the name boot.

Open a file named config.txt, where you must add these lines at the end:

# Disable the ACT LED.
dtparam=act_led_trigger=none
dtparam=act_led_activelow=off
# Disable the PWR LED.
dtparam=pwr_led_trigger=none
dtparam=pwr_led_activelow=off
# Disable ethernet port LEDs
dtparam=eth_led0=4
dtparam=eth_led1=4
6 Likes

There’s no need to shutdown the Pi and insert the SD card in your PC. It can be done over SSH and configuring config.txt

sudo nano /boot/config.txt

enter the lines above then save
Ctrl+X, Y, return
then restart umbrel through the web UI.

9 Likes

Very useful @Aydo, thanks!

1 Like

Had to sudo reboot, but this worked! Sweet. Stealth mode!

/necropost on

Yes, thanks very much @Aydo and @ibertario - this is a very neat trick…but I can’t get mine to work.

I’ve edited the config.txt file several times now with nano, and I can see the successive changes I’ve made, but after several software- and hardware reboots, I still have the blinking Christmas tree Umbrel with all of the LEDs lit up / flashing strong.

Any ideas why it’s not working? Here is the relevant section of the config.txt file with the new additions:

> # Disable the ACT LED.
> dtparam=act_led_trigger=none
> dtparam=act_led_activelow=off
> 
> # Disable the PWR LED.
> # dtparam=pwr_led_trigger=none
> # dtparam=pwr_led_activelow=off
> 
> # Disable ethernet port LEDs
> dtparam=eth_led0=4
> dtparam=eth_led1=4
> 
> # Disable WiFi
> # dtoverlay=disable-wifi
> 
> # Disable Bluetooth
> dtoverlay=disable-bt

Hello,

Do you have a Pi 4? I tried your settings on my Pi 4 (uncommented both PWR LED as well) and they work. All lights were off. My settings were:

[pi4]
#Disable the ACT LED.
dtparam=act_led_trigger=none
dtparam=act_led_activelow=off

#Disable the PWR LED.
dtparam=pwr_led_trigger=none
dtparam=pwr_led_activelow=off

#Disable ethernet port LEDs
dtparam=eth_led0=4
dtparam=eth_led1=4

1 Like

Sorry - yes - Pi 4 B with 8GB RAM, 1TB drive all in a Geekworm NASPI enclosure that uses their two boards. https://geekworm.com/products/geekworm-naspi-2-5-sata-hdd-ssd-kit-for-raspberry-pi-4-model-b

Perhaps that’s the problem - the LEDs are being powered by the Geekworm auxiliary boards? Apologies - this is my first ever RPi, and I’ve pretty much only ever had it in this enclosure

fixed using a small piece of tape to hide them.

1 Like

I recently tried to do this after upgrading to version 1.0.4. However, I get the warning that “File ‘/boot/config.txt’ is unwritable” when I try to edit with nano. What do I need to edit this file so that I can turn off the LEDs?

Der „sudo make me a sandwich“ robot | Linux und Ich

Tried with sudo ?

Yes I tried with sudo. Same result.

UmbrelOS seems to make config.txt unwritable in Debian 12 (bookworm), it’s locking the file somehow. I haven’t dove into this too much. Hopefully a dev can shed light on this for us and if a workaround is available.