Upgraded to 1.0 and cannot edit config.txt

I upgraded to 1.0.4 and can no longer edit my config file to turn off all the LEDs as it was able to before. I get an error that config.txt is a read only system file, even when I try to edit it with sudo.

What’s the workaround here? I can’t sleep with the flashing lights on my pi 4 in my room.

1 Like

I had the same problem, had to need to edit the /boot/config.txt file because I needed to open the PWM device tree for the raspberry pi 4 for Geekworm X735 product. Hopefully there will be an official response to this issue.

I have a similar issue in needing to set gpio-fan parameters for controlling the official rpi 4 case fan when temperature breaches a threshold, previously set using raspi-config which updates config.txt, but that doesn’t work with umbrel OS (errors writing to read-only system file). Hope for an official response soon.

What I’m doing now is using RPi.GPIO to write a script in python to run the PWM fan, but I’m still hoping for an official response to this: e.g. to use the command rw to enter writable mode, as PiKVM does.

Hello,

Just here to bump this for the DEVS,
I have a beautiful Argon One case for my RPi 4
The built in fan requires a script to monitor the CPU temp and activate the fan as needed
the script requires i2c to be enabled
I cannot edit the config.txt to add the required line,
raspi-config is not present
there is no file present at /boot/firmware/
there is no persistent user-config.txt that I can find anywhere.

For a platform that values user autonomy as much as this project claims to, they seem to be consistently making programming choices that limit the options and control that end users have over their devices.

in the spirit of “not your keys, not your crypto”
Umbrel needs to remember “not your config, not your device”
Limiting our control of our own devices is hardly different than centralized control of our devices.

We deserve the option to configure the OS to suit our specific hardware requirements.

I was already struggling with a Nextcloud deployment without SSL as MANY Nextcloud apps will not function properly without SSL, but now I cant even run a fan script.
This might be the final straw for me.

Ohh, look at that - have a problem after upgrade on 1.0 and found out the very same issue (while in it would like to handle the LED’s as well).

Just my 2 cents around the issue.

They stated somewhere the OS is with a upgraded filesystem, in 1.0 and newer, to better handle SD cards - so maybe it’s the reason.