ThunderHub Ignoring Outbound Channel Selection

After the latest ThunderHub app update, it is ignoring my outbound channel selection when sending sats. It randomly picks a channel. The channels I select to send from have plenty of outbound capacity and this is making it extremely difficult to balance my channels. I usually balance by sending sats back and forth to/from my BlueWallet. Curious if any others are seeing this as well?

Why this obsession with balancing channels?
Are you a merchant that accept BTC on your LN channels? You need inbound liquidity?
If not, just adjust your channels fees accordingly and let the LN “magic” do its thing. No need to move funds in/out just to have perfectly balanced channels. Only if you like to spend valuable sats in these rebalancing txs.

You are so testy Darth. I guess it is the price of genius. I balance to feed the liquidity used by given channels. For example, some channels ONLY receive inbound traffic to my node and once it is all pushed inbound, the channel sits there without any transactions until I create some inbound liquidity again by sending sats to my wallet. I’m sure you know this. It was nice to be able to select the channel I needed the sats to go out on when I wanted to balance. And, yes, I value my sats and I don’t make money (I do lose money) with rebalancing, but I wanted to help enable traffic. Thanks for you all you do to help (I’m serious about that).