'Starting Umbrel'

Having synced to 90+% - am getting stuck at ‘starting umbrel’ page. Have reset node but no avail. Any help greatly appreciated.

  • Device: Raspi 4
  • Connected via Ethernet to router
  • Using Samsung 1TB SSD
  • Synced to 90%

Have seen other examples of the issue, however havent seen a fix as of yet.

Hey hutbit, thanks for posting this here, if you’re able to SSH in, can you help provide us some logs so we can take a look?

Hi Jon, Thanks for the reply. Trying to SSH in on terminal. Have followed the instructions and upon trying to enter my password I am just met with a blank curser before seeing the following prompt about 60 seconds post hitting return:

umbrel@umbrel.local’s password:
bash: “~/umbrel/scripts/debug”: No such file or directory
Connection to umbrel.local closed.

Hm, can you just try SSH’ing without the second command? (so just “ssh umbrel@umbrel.local”, and then put in your password), just seeing if you can even get in.

If you’re able to get in, then try running

If that doesn’t do anything, can you just type ls and screenshot that? Curious if the folders even exist.

Hi Jon,

This is what I have got so far:

ssh umbrel@umbrel.local

umbrel@umbrel.local’s password:

Linux umbrel 5.10.63-v8+ #1459 SMP PREEMPT Wed Oct 6 16:42:49 BST 2021 aarch64

The programs included with the Debian GNU/Linux system are free software;

the exact distribution terms for each program are described in the

individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent

permitted by applicable law.

Last login: Sat Dec 11 20:00:54 2021 from 2806:1016:1:ec9d:8047:4e51:1522:199f

Also see results of ls command:

Screen Shot 2021-12-11 at 3.19.41 PM

Hm, were you able to run ls while ssh’ed into the umbrel? This is the folder structure of your Windows machine.

The ssh command above output the right stuff, you were logging in - assuming it didn’t kick you out, ls should’ve showed you just the umbrel/ folder.

No, unable to run ls when ssh’d in. Screen Shot 2021-12-11 at 3.32.12 PM

Thanks for your help so far :slight_smile:

So are you not receiving a command prompt at all? It should appear eventually (don’t exit, otherwise you’re disconnecting from the umbrel).


Not that i can see. This is all im getting Screen Shot 2021-12-11 at 3.40.14 PM

What program are you using to ssh with? Is it Powershell or something else? (also, I’m guessing your on a Windows machine)

Terminal on Mac. Managed to run the debug script with this output

There should be quite a bit more after that (it’s pretty common that it looks like it’s stuck for a bit right where you’re at, but then more comes after). You could also copy/paste all that text into something like pastebin.com instead of screenshotting it

Hi Jon,

Thanks, that was all i got before i was disconnected - I left it running for a long time with no more outputs.

Hm, it seems a little odd that you’re getting disconnected like this, would you be able to reflash your SD card with the Umbrel image (your funds shouldn’t be impacted, but make sure you have backups just in case).

Hi Jon, reflashed the SD and it seems to have worked. Thanks for your help. Best

Awesome, glad that worked!