Samourai server hotfix 2

I get an error message when trying to connect Whirlpool GUI

unable to connect to wallet backend http://samourai-server_nginx_1:80/v2/

everything waa working well before the app samourai update


Hi @noetik can I confirm you are now running the latest version of Samurai Server version 1.16.1-hotfix-2?

Can you try to uninstall and reinstall the app and let me know if it resolves the issue (via clicking “Manage Apps,” clicking the Red “X” on Samurai Server, and then reinstalling from the App Store)? Happy to further troubleshoot.

Hey, I tried that already including rebooting and stop starting multiple times…As soon as I enter my password to unlock the wallet I get that error message

Is there a way to restore to previous samourai-server version. The latest update rendered whirlpool unusable for me.

Hello, I am getting the same error. It was working fine until I upgraded to the latest version of Samourai Server. Is there a way to rollback or load an older version? Thank you. somebody from the samourai wallet telegram group posted that link which in turn led me to hard code the ip address instead of the variable…

This in essence is a very ugly short term solution but it works. If you stop the samourai docker container with this fix you need to log back in the container to get the ip address as in my case the ip can change which lead me to re-edit the docker-compose.yml file to retrofit the ip address…

In essence, if you apply this fix and dont restart the docker container or restart your umbrel appliance you dont need to do anything exept wait for the samourai-server update to fix it.

Hopefully the update will come soon.

1 Like