How to connect Whirlpool to Samourai Wallet

I’m getting this error: “Authentication failed: Authentication failed: invalid passphrase?”

I followed the step one in Umbrel to connect my Samourai wallet to Dojo.

Then in step two I followed steps to connect to Whirlpool GUI. However after I complete step 8 and connect Whirlpool to CLI on Umbrel ; it doesn’t give me the option for step 9 which is “Click QR code icon to scan a QR code from Samourai Wallet on your phone”. So when I go to Authentication in Whirlpool GUI, and try to enter my Samourai wallet passphrase, it won’t work.

Has anyone else run into this issue?

1 Like

Same issues here. I have been able to get up to step 9 once now (most of the time I’m unable to proceed past step 8, after which I get “Connection failed: Could not connect to CLI (may take a few seconds to start…)”. I was able to get through the QR code scanning but after that when I attempted to put in my BIP39 password I received an authentication error (technical error). When I type in an incorrect password I get a different error so I’m certain I’m putting in the correct password.

I attempted rebooting my Umbrel and returned to getting stuck connecting to CLI after putting in my API key. I understand this is a beta product but based on my looking around this seems to be a rather chronic error for an important app. I’m curious whether it’s up to Umbrel or Samourai to debug and resolve these sorts of app-specific issues.

Hello guys!

Having the same issue here…! Was able to connect once. But I did with the wrong wallet on my samourai wallet app. So I restarted every steps with the right wallet in the samourai wallet app. And now I’m sticked to step 8. I can’t connect to remote CLI! Got this error : Connection failed: Could not connect to CLI (may take a few seconds to start…)

I’ve tried to uninstall/install whirlpool and the samourai app. But it did not work.

Moreover I can’t see one utxo I received yesterday on my samourai wallet which is connected to my umbrel dojo. I contacted the samourai support which redirected me on this tutorial (missing balance part)–>

Seems like there is an issue with the samourai umbrel app.

Is it possible to have acces to the maintenance tool to check all those things ?

Many thanks

Hello guys,
I found the way to use the maintenance tool… I was quite blind… When you launch the samourai umbrel app, they explain how to do it… :smiley: Balance issue is now over.
And in other way, things get better on the dojo. I was finally able to connect to the CLI.
Every things is fine!!!
Big love

@Pierre How did you fix this? I have never ever been able to get past “could not connect to cli” error. Have tried many reinstalls etc. had hoped that Umbrel updates would fix it but they haven’t.

Hi @copacetic!
Have you check through the maintenance tool of the samourai server if everything was working fine ?
Moreover, on your computer are you using tor through the Tor web browser ? If so, have you put the right port in the gui config, and have you open Tor browser while trying to connect the gui ?

Not sure that I follow – I have Tor installed (via Terminal), though I’ve been accessing Umbrel/dojo through Safari. Are you saying that I’m supposed to be using the Tor browser itself? I’ve never heard or seen anything about this.

And yes, the Dojo maintenance tool says everything is fine (all green checkmarks).


In the gui config, you have to put the right port according to the Tor usage :

You can install Tor via terminal, you should put the port --> 9050 (never tried this one)
And you can launch the Tor Browser before launching the Gui and in this case, the right port is --> 9150

In my case, I m using the gui with the Tor Browser opened, so i configured the gui with the port 9150