Samourai wallet showing 0 balance since 0.4.1

My wallet is showing zero balance with no outgoing transactions to justify this. The 3 deposits i’ve made into it are showing with no outgoing transactions, yet the balance is completely empty. The wallet is connected to samourai server on my node.

Obviously this is very concerning. I spoke with samourai and they said it is likely an issue with the 0.4.1 upgrade and that my funds could be restored by the seed phrase to another wallet. Do you have any advice for this?



I looked in the Umbrel logs and there are some error messages saying aborted connection to Samourai server if that helps to explain

My Samourai wallet is the same. Have Umbrel been able to help users with this issue yet? Seems with every update I end up with issues trying to run Ronin Dojo via Umbrel… Appreciate any help/advice on this. Cheers :slight_smile:

I sent $1000 from my Exodus wallet to a Samourai + Umbrel node wallet without checking if it worked on smaller amounts because I’m a fucking idiot.

The funds left Exodus, but they did not appear in Samourai. Naturally, I was a bit nervous. Deleting and restoring the Samurai wallet didn’t work. I contacted Samourai support, who said, “It appears your wallet may have been somewhat out of sync with our nodes. I’ve just resynced our nodes for that address, and you should now be able to get your balance and transaction history displaying properly in Samourai.” I was able to send my funds from Samourai back to Exodus after that.

So Samourai doesn’t seem to be working with Umbrel for whatever reason.

1 Like

I have a similar issue.

I downloaded the Samourai wallet on my phone and followed instructions to connect Dojo by using my Umbrel node which runs on Rasberry pi.

I made a small deposit into the wallet as a test but it didn’t show up. It still says 0 balance and 0 transactions.

However, if I check the public address on Bitcoin Explorer, it says the wallet has the right balance with a single transaction.

I’ve tried reaching to the Samourai support team but they couldn’t help. They said “Please follow up with the Umbrel support team for assistance on that as unfortunately we are unable to provide in depth support for third party Dojo implementations such as that of Umbrel”

What’s my best bet to get my bitcoin back? recover the funds with a different wallet provider? wait for a resolution for this issue?


Use the XPUBS Tool in Dojo and rescan your XPUB (can get it in Settings --> Wallet in the Samurai App).

That worked for me, but now I’m struggling with Whirlpool transactions missing since I had to reinstall Dojo because it stopped syncing (Major Issue #2).

Edit: Be sure to ‘Retype’ the scan as BIP84 before rescanning.

1 Like


I had tried that as suggested by the Samourai support team but it didn’t help.

I tried uninstalling the wallet app and reinstalling it, now I can’t even connect Dojo.

Maybe lack of synchronization between wallet and node is why I’m having trouble?

Any more suggestions?

Did you recover the funds via seed phrase or find anyway to get the funds out of whirlpool? Mine are stuck also

Did you figure out how to get it to resync? Mine is also off sync for trackers and DB.

I have the exact same issue as the thread starter.

I recovered the wallet and connected to the wallet provider’s node. I had to additionally go to Settings/Troubleshoot/Send backup to tech support to get it to sync and display my bitcoin.

Hi, I just hit this problem on 0.4.5. I installed Samourai Server, scanned the QR into a fresh Samourai android app, sent some coin to it, and saw 0 balance, even after 60 confirmations on the blockchain.

I installed 0.4.6, and for me, the XPUBS tool didn’t work, but the Addresses Tool did. If you have the addresses you sent to, enter them into the Address Tool, and click “Rescan This Address”. In my case, it found the balance on the address after the rescan. And the balance now shows up in my Samourai android app as well. I had to do that for every address.

I can’t seem to find the address that I sent to… I sent from Green Wallet to SW. Can’t see the address in Green Wallet or on the Block Explorer… am I missing something?

I had exactly the same problem. Installed my DOJO, connected a new Samourai wallet to it and sent some funds, balance 0. It seems like some sort of bug with Umbrel and this is super concerning that many people face it while there is nothing about it in Umbrel docs.

The way around it - import your seed into a BIP39 compatible wallet (Coinomi, for example. Not Electrum!) and this is how you can access your funds.

Giving lack of tech support for this, I am going to remove Umbrel and install native Samourai version of dojo. Good luck everyone!

P.S. I have found a solution how to fix it! All you need to do is go to dojo maintenance tool and click block rescan. Enter a range of blocks around the block where you transaction is and this is it!

I really don’t understand why people still use this kind of mixing when you have a perfect mixing tool: Lightning Network!
Please check this guide and stop wining about Samourai/Whirpool/mixing is not working.

Be smart, adapt, evolve and let the chain analysis shit to look into meaningless onchain txs and meanwhile you are mixing on LN.

Another example here

I’m having the exact same issue. I worked with Samourai support but after running through several trouble shooting steps, they determined the issue is on the Umbrel side and syncing. They said they have seen this issue a fair amount recently.

I went through the dojo maintenance tool and the block rescan but had no luck. They recommended checking this community and the samourai dojo telegram.

I am at the point I will likely just switch back to the Samourai nodes to recover my funds.

I am having this same issue. Installed Dojo and connected wallet. Everything seemed fine. Sent a small transaction and balance at 0. Sent another tx and still 0. Tried all of the potential fixes mentioned above with no results. Does anyone have a fix for this yet?

My samouray wallet shows 0 funds.I talked with Samourai support but after running through several trouble shooting steps, they determined the issue is on the Umbrel side and syncing.

I went through the dojo maintenance tool and it shows my real balance with confirmations and all (NOT the whirlpool ones). Help.

Are you able to generate any logs for us to look at? Seems like the issue is happening intermittently, so it’ll help us troubleshoot

Sent u an email.