Resyncing Blockchain has taken 11+ days

I don’t know what happened when I upgraded to the latest, or if installing Samourai did it, or if trying to run rsync on the whole machine did it, but the blockchain stopped syncing. I ran -reindex and it’s at 90.77% after 11 days. I’m on an SSD on the recommended 8gb Pi, over ethernet. I can’t believe this takes this long. From what I read, it should take 2 days. I’m worried that this -reindex won’t fix my original problem. I guess I just have to wait another day or more to see.

There’s got to be a faster way to bootstrap a node, right? I don’t think I can deal with 2 weeks of downtime for an unknown error again.

Thanks gang.

Did it stop synching totally? or did it just slow down?

It took me about 3.5 - 4 days to sync to 100%. The last ~ 20% took at least as long as the first 80% … so it does slow down a bunch towards the end.

Do you have fast internet? If your computer is connected via ethernet you can get the speed using fast. I found this site that tells you how to install a speed test on a Raspberry Pi, but I haven’t tried it on my umbrel node.

If you want to make sure you still have internet going to the umbrel you can ssh into it (type “ssh -t umbrel@umbrel.local” in the terminal/powershell and type in your umbrel password). Once in, you can type “ping” to ping Google and see if you still have internet. Hit “cntrl key + C” to stop pinging.