Recovery from seed / no balance

I have startup a new umbrel after a power failure.
Raspberry Pi / umbrel version 0.4.0

I could spin up a new umbrel from the 24 word seed,
Blockchain is synchronized 100% but balance is zero
I did a recovery of LN channels (2 channels opened) by copying the channel.backup file and

$ ./bin/lncli restorechanbackup --multi_file /home/umbrel/umbrel/lnd/data/chain/bitcoin/mainnet/channel.backup

Channels don’t show up either.

I can access the on-chain balance with Bluewallet and the UTXO are sitting were they were after the failure. It is like umbrel is not looking at the right addresses, and there is no wallet file in bitcoin folder

I do know the two channels, are still open because I can see them in doing a search with the node id I can get com RTL app.

I am frustrated because I have resync’d 3 times already but the result doesn’t change, my balance is still zero and LN channels cannot be recovered.

This is my backup id

cat karen.log | grep 'backup ID' | tail -n 1
{"message":"Successfully uploaded backup 1629363238800.tar.gz.pgp for backup ID 61438adef8b3960755db3c2ee2c02c79447e9f71371199cf0fb1c1a4e1047977"}

If you restored from seed and SCB, your channels were forceclosed and your fund will return in 2 weeks to your onchain wallet. That’s how restore works. Info on is simply not actualised. Just wait.

1 Like

I had a fair bit of trouble like this while restoring as well.

One thing you can try is to tail the lnd.log and see if you can pick out any issues.

Navigate to (I think) \umbrel\lnd\logs\bitcoin\mainnet and run tail -f lnd.log

If nothing stands out, another thing you can try is to force your node to rescan for transactions (this is how mine ended up showing at first, and made me more confident).

When you do this, try watching the lnd.log when it is scanning, and again see if anything stands out.

Ultimately, even though I started seeing UTXOs recognized, I still had issues and had to rest my user data on the node one more time (Seed and username/password). You can do this without downloading the blockchain again.

Can’t guarantee any of this will work. It took me about a week of trying things like this to get a clear win and get all of the funds off.

Anyway, if at any point you see some transactions, but not the funds from your channel closures, you can always run the SCB procedure again to see if anything changes.


Hmm with 1ML you need to check the last time it updated, this is in the ‘channels tab’ and look for the ‘Last update’ to confirm it has updated recently and if it is, then you’ll be able to see if the channels have been closed or not.

Thanks fireworksurprise!

I think your proposed solution points in the right direction, I will try it out.
I am definitely convinced the problem is related to the addresses that umbrel looks at and rescan seems conceptually right.

I realize that the rescan is done by a modification in lnd.conf


and not the Bitcoin core set up or a wallet (by the way, there is no wallet.dat in umbrel, something I still don’t understand)

Anyways I will follow your recommendation and let you all know.

Thanks indeed

Thanks Vilas.
I did restore from the seed and SCB. I will wait for a couple of weeks to see if channels are closed.
But still my umbrel doesn’t see the on-chain balance.
There are few TXs I did in my Ari GI la set up (before the power failure) and there is still an UTXO that I can see with Blue Wallet. it is still there but for some reason umbrel does not show it.
It must have something to do with the addresses that umbrel looks at.
Why the new umbrel (recovered with same seed) doesn’t not look at this same addresses (showing my original TXs) is something I don’t understand.

Shouldn’t be the addresses determined in the same exact order in any set up when you use the same seed, as in any other wallet I have used? Actually, I can see the TXs if I use the seed in BlueWallet.
Any way to tell umbrel to rescan more addresses?

Thanks for taking the time to help.

I have the same problem.
I will wait 2016 blocks (14 days) after restoring by the seed, too.
But I have still the fact, that the Umbrel Wallet shows zero balance and blue wallet with the same seed shows the old balance. I even could transfer a small part from the blue wallet to another.

@PlatoWright Did you recieve the funds out of your old channels? And does your Umbrel Wallet shows a balance now?

Best regards from Cologne

Yes it did work.
When using the channel backup, it closed the channels returning the balanco to your wallet.
I had a problem with one of the channels (opened with which didn´t get closed. But I performed the recovery process again and, this time, the channel got closed.
My guess is tha the recovery with the SCB tries to close the channel shaking hand with the peer, and, if it is not available it doesnt force-close it. So if you try again some time latter, it will succeed.

I had an issue with the lnd.conf which kept reseting the wallets transaction
This re-scanning takes a long time to do as it performs a rescan of the wallet addresses. I had to do it the first time I tried the recovery but if you leave it, it starts all over again everytime you startup your umbrel

After I completed the recovery process (closing channels) I had to to comment it
# reset-wallet-transactions=true
which I guess is equivalent to de default option

Hope this helps

Hello again,

yes it worked! Thanks a lot!

Strange, I do not see that line on my conf file.
You said that the line appears after you initiate the restore/force close the channels?

Well, I ca not asure how or when that line appeared. I could even include it myself while trying to solve the issue. But the described process worked out. Sorry for not being able to give you more details

I am a bit confused as I have two nodes running with the same seed. I set one up on slower non ssd but transfered bitcoin to it before fully synced. Balance showed up. I lit up sencond node with ssd with same seed and is now fully synced but no balance. I did not open any channels on first node. will this fix this or should i be looking elsewhere.

Nevermind I just copied the wallet.db file. I am a bit confused as I thought the wallet was based on the seed used to setup the node. Am I wrong in that assumption?

I have had the same problem when recovering from the seed.
I must say that every time I recovered from seed I copied an already downloaded blockchain and this might be the source of the problem (@GrandArcher did you copied a downloaded blockchain in your second umbrel?)

Copying the blockchain was a pretty simple process and I think it worked fine (scp, check permissions and owner, etc) and once copied you startup umbrel and shows 100% sinchronized.

Then you need to wait for electrum server to catch up and in the end the umbrel is fully sync’ed and running, but the balance is wrong

I don’t understand how addresses are selected, derived or scanned (electrs).
I am not confident on the recovery process. Every other wallet has a predictable outcome when you use the same seed but I don’t get umbrel’s way of selecting addresses. It is sad because I really do like the umbrel concept, it is a fantastic project but in the end I don’t understand it (or have confidence) as to store sats on it.

1 Like

I’ve been following this thread for a while now since I’m having the same issue. I waited the recommended 14 days and a few extra days but it is still showing a 0 on chain balance. I have tried the command to rescan wallet utxo before and after waiting the recommended days but still nothing. This problem is on my Umbrel’s end because I can see my balance when I put the seed into Blue Wallet.

There si an issue opened in github to follow this. I’d suggest we all give our comments there so developers can look at it.


I did not copy the blockchain initially but a couple of days later I did because of how slow it was.

OK it’s been more than three weeks now and still my funds are missing. Any advice? Anyone? Bueller?

1 Like

After a seed recovery, LND enters a recovery mode that searches for past used addresses
If this is disrupted, this can cause the wallet balances to be missing

I was able to resolve this issue by following these instructions

1 Like