No Balance and Lightning Channel recovery after Node reset

Hi guys,

after having a lot of problems with my node because of not enough RAM I bought an 8GB Pi and totally reset my Node.
The IBD is done now since a few days, but my Bitcoin balance (OnChain) still does not show up. When I try to recover my LN Channels I have no Option to choose a backup as well. (Always showed up on the old node even If I had no more open Channels)

I checked if I put in the correct seed phrase and I did. (Printed out, checked word by word)

What am I missing?

Hi @J0nsan, could you please share what you get when you open the ‘Recover Channels’ menu under the lightning node app’s advanced settings. Thanks

Exactly the same like in the picture you sent. I can only choose a file. When I reset my node the last time I just had to choose the correct one from the menu.
I still have a very old backup file downloaded because I was not able to access my node anymore before resetting. But even If I manage to recover the lightning channels my on chain balance will still be gone.
The on chain balance is way more important than the few LN channels that may still be open.

Ok, let’s sort out the onchain balance first.
Please see the below procedure for rescanning for your wallet’s UTXOs

I can see a log that mentions an old back-up in your post history- I will forward this to the team, and see if we can find your most recent back-up with that given you don’t have it downloaded.

If I ssh into my umbrel and run the command i get “sed: can’t read /home/umbrel/umbrel/app-data/lightning/data/lnd/lnd.conf: No such file or directory”

Apologies, that file is now umbrel-lnd.conf

Please run the following first

touch ~/umbrel/app-data/lightning/data/lnd/lnd.conf

then

sed -i “s/[Application Options]/[Application Options]\nreset-wallet-transactions=true/g;” ~/umbrel/app-data/lightning/data/lnd/lnd.conf

I ran the command “sed -i “s/[Application Options]/[Application Options]\nreset-wallet-transactions=true/g;” ~/umbrel/app-data/lightning/data/lnd/umbrel-lnd.conf” and restarted my lightning node. How do I know if the re-scan completed?

Give it at least 24hrs, but the process should show your onchain balances in the lightning node app when complete.

We do seem to have recent lightning back-ups- approximately when was your lightning node last online and working?

About the 11th of August was the last time the old node was “online”. At this time I already could not open apps anymore but It seemed to still be online. There should not have been a lot of changes to the LN channels the weeks before that. I sadly can’t say which date exactly because I had a lot to do at that time and the new raspberry pi took its time being delivered.

I still have one old 24 word phrase that I was sure of to be empty and not in use since the beginning days of Umbrel being published. (I had to reset it for some reason then) For the off chance I actually mixed them up: I guess I could import it into e.g. Exodus and look if there is a balance on it right?

1 Like

Same thing happened to me because I ran sudo apt update and updated docker - screwed my whole setup up. Ultimately had to totally clean docker out 100% and reinstall Umbrel. Vowing never to run that on my Umbrel system going forward

My balance still does not show up. I could reset my node completely again. But I don’t know if that changes anything. The 24 word phrase is still the same…

Hey guys, is there anything I can do? I would love to keep on using umbrel, but unless I know where my balance went I dont feel save putting anything on it again. If I could at least put in my 24 word somewhere to check past transactions, that would help a lot.

Ok for the onchain side, please try this. Download https://zaphq.io/ and use your 24 words seed to restore the AEZEED onchain wallet.

Please let me know how that goes and we can continue with the lightning side.

So I used BlueWallet because ZAP is no longer maintained. The balance shows up there as it should. So at least I know have my money.

I still can’t figure out however why the umbrel still shows nothing. I rechecked the seed again and its definitely the same one I imported into BlueWallet.

Any ideas how to proceed?

Just to confirm- have you also tried just uninstalling/reinstalling the lightning node app specifically? I believe this should also conduct a rescan.

Outside of that, asking LND to rescan with reset-wallet-transactions=true is usually effective, so I’m not sure what the issue here is unfortunately.
Have you recovered all your funds now?

Just did both of that again and surprise: now the balances actually show up.
So now I guess I would have to do it over again to get a new 24 word phrase to be safe right?
Or is it “safe” (enough) if the 24 word phrase was just entered into bluewallet and nowhere else?