Umbrel Bitcoin wallet empty after restore

I had an issue with my Umbrel and decided to just wipe everything and start over . Flashed the SDcard, erased the HD and started fresh. When prompted I used my previous seed phrase to restore my bitcoin wallet in Umbrel when setting up. Currently I am 100% synced and have 0 in my bitcoin wallet ( there should be 20k stats ). I never opened any lighting channels, etc… I can see the balance in my mobile Bluewallet after I used to restore via the recovery phrase used in Umbrel.

Am I missing something ? I expected the recovery phrase restore my bitcoin balance and show in Umbrel like it is on my Bluewallet . ?

Yes, you have to wait at least 8-12h until electrum server is indexing the blocks.

1 Like

Thank you,

It has been over 24 hours. I checked the electrs log, it appears to be done indexing… I cannot recall but the stats may of been in the lightning wallet, again no open channels never used lighting wallet except to possibly receive the sats from the bitcoin wallet, etc. It may of had the sats in there however. Does the seed phrase restore both the lightning wallet and the bitcoin wallet ? I do not have the channel backup as I did not think I would need it since I never opened any channels.

electrs | [2021-10-25T15:08:44.456Z INFO electrs::index] indexing 1 blocks: [706646…706646]
electrs | [2021-10-25T15:08:44.620Z INFO electrs::chain] chain updated: tip=0000000000000000000d60a6d0b9122a6865e5a04c0ffc3f6908f5a9f3441f84, height=706646

Umbrel use aezeed LND wallet.
That means the seed will restore the onchain wallet but not the channels funds.
The channels are restored only with the same seed and in the restore process will be closed and funds back to onchain wallet.

If you do not opened any LN channel, the seed is enough.
If you open some channels, you will need to do also a backup of the channels and that file will be used in the process of restore.

Ok thanks, that is what I thought. I for sure did not open any channels. So I’m not sure why the wallet ( bitcoin or LND wallet) show no funds in Umbrel, yet entering the seed in blue wallet does show the funds… I have verified that the seed is correct in Umbrel and is the same one used in the separate mobile blue wallet. Since I did not open any channels.

Thanks for your assistance !

@Synicasm. I’ve experienced similar problems when restoring umbrel from the seed. It is a bit unreliable.

It is not clear to me how the addresses are derived from the seed or it might be a problem with electrs (electrum server). My impression is that it fails in looking at the right addresses or there are inconsistencies in which is the first address to look at when you do trestore from the seed.
As an example, I could see funds in Blue Wallet (BW) sitting in the early addresses of the wallet but those could not be seen in the restored Umbrel. I could check that the addresses given by umbrel (clicking on “RECEIVE” tab, are the correct ones (same as in BW) but umbrel cannot see the UTXO. However but if you do a brand new transaction to any address provided by the restored umbrel, it will show the balance.

I have been days trying to recover, tried several times, checking the HDD, restoring from scratch every time and I still think that umbrel recovery is not consistent.

I must say that every time I recovered from seed I copied an already downloaded blockchain (otherwise it would have been to much time). This might be the soruce of the problem …
Copying the blockchain is a pretty simple process and I think it worked fine (scp, check permissions and owner, etc) and once copied you startup umbrel and shows 100% sinchronized.
You need to wait for electrum server to catch up (as @DarthCoin says) and in the end the umbrel is fully sync’ed and running, but the balance is wrong … I will wait to be more familiar with the process before I put more sats on umbrel.

@platowright You were exactly right. I looked in my mobile blue wallet and compared the address that was available to what address was in Umbrel’s receive. Umbrel’s receive address was listed as one of the 21 addresses listed in my mobile Blue Wallet. In Umbrel I went to the home screen and back to the bitcoin screen and checked the receive address and it moved to the next address in the list that was on my mobile blue wallet. So I sent my sats from my bluewallet to the Umbrel wallet with the minimum fees ( about 7cents ) and the total in my Umbrel wallet instantly listed them. The transaction is still pending in my blue wallet with a time of about 3hrs, however. I think you are right there is something odd about restoring from the seed phrase and not looking at all the addresses for funds. Thanks for the tip !

So now, my mobile Blue Wallet has a zero balance while my Umbrel bitcoin wallet has a balance. Same recovery seed used for both wallets… not sure whats happening here…

Hey, I’ve been trying to fix this problem for about 4 days now. I’m in a very similar situation as you guys, the only difference is that I downloaded the blockchain from scratch. I had no luck.

In previous releases, the balance was initially 0 but it updated quickly while it was still syncing. I thought it would be the same now, but I was told that I had to wait until electrum finished indexing the blocks, so I did. Now here is where I think the problem comes, while the logs are indeed showing me that electrum is done indexing, it’s showing me a lot of warnings looking like this:

[2021-10-26T08:34:19.093Z WARN electrs::p2p] unexpected message: Unknown { command: CommandString("addr"), payload: [1, 48, 187, 119, 97, 9, 4, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 255, 255, 165, 22, 227, 159, 71, 157] }

They appear every couple of minutes with different payloads. I have no clue what those warnings could mean.

Everything else is working, just like your nodes. But I don’t want to use blue wallet, I want to use umbrel. Resetting everything is not fixing the problem.

@fig. Same as in my case. I am pretty sure the problem is with etectrs. That is the reason why balance is wrong, because the addresses are the right ones (if you check umbrel’s addresses with the ones in Blue Wallet).
I refreshed electrs yesterday (by deleting the folder’s content except for the electrs.tom file) and it started reindexing with the same outcome in the electrs logs.

@fig I too restarted from scratch pulling the whole blockchain down. However my electrs log looks clean only indexing entries for the latest new blocks I checked the entire electrs log for ‘payload’ and there were no entries… docker-compose logs | grep payload

That’s interesting. It makes me whink that the problem isn’t electrs but something else.

Anway, I could get my original balance to show again in my node following this. I think it’s not ideal to force a rescan, but it’s a good solution in the meantime.

Thoroughly confused here. So I deleted the “imported HD Aezeed” wallet from my mobile blue wallet that said there were 0 funds ( after transferring them to the Same wallet on umbrel yesterday) . Re imported the same wallet with the same seed phrase and now it shows the funds with a bunch more addresses. As a Guess… It Seems like the Wallet in whatever place it is at does not update ( or rescan whatever) unless some new transaction is sent to an existing address the wallet already knows about.

For example When I originally restored my wallet to Blue wallet there were only 21 addresses. Today, there are now 43 addresses after restoring it to blue wallet again.

This leads me to think that the Umbrel wallet is not rescanning existing addresses of the wallet. I suspect if I would of used the rescan that @fig suggested it might of fixed things. Regardless something is not working well with the recovery process it seems.

1 Like

That’s a whole twist! So it seems that the recovery process is bad from the very source and has little to do with umbrel itself. Please run the rescan and keep us informed of your outcome. Good luck!

Ok So here’s were im am at… I took a chance and decided to run the rescan for fun to see how it would work. Following the instructions here After my Umbrel node restarted the balance was zero in my wallet. Checking the lng.log “tail -f umbrel/lnd/logs/bitcoin/mainnet/lnd.log” I see this…

2021-10-26 18:58:46.445 [INF] LTND: Waiting for chain backend to finish sync, start_height=706826
2021-10-26 18:58:47.623 [INF] LNWL: Started rescan from block 000000000000000000080d4dae8011c69dcb8bf67fd062a93d1e70e08dfd65de (height 701460) for 27 addresses

After a little while the balance updated to 22,817 sats. ( im assuming this is updating the balance on the fly since there should be 22705 sats since I transferred the sats from my wallet to the same wallet different address costing 112 sats. yesterday 22817 - 112 = 22705 . This is the reported balance in my mobile blue wallet. )

After the scan was complete the balance correctly updated to 22705…

2021-10-26 19:57:59.631 [INF] LNWL: Catching up block hashes to height 706835, this might take a while
2021-10-26 19:57:59.633 [INF] LNWL: Done catching up block hashes
2021-10-26 19:57:59.633 [INF] LNWL: Finished rescan for 27 addresses (synced to block 00000000000000000009de6dfed386dd4d3730c3de5492e4de406e49d41fe218, height 706835)

Im going to guess that the wallet restore happens before the blockchain is downloaded, Maybe thats why they funds dont appear…

1 Like

I have same issue.
I tried to rescan, but I can’t find my on-chain balance.
Looking at lnd.log, it looks like it wasn’t rescanned correctly. It says that ‘rescan for 0 address’

2021-10-23 01:04:52.373 [INF] LNWL: Started rescan from block 00000000bee289ec0a937b27a2a3fd9164c96c97dbd7c4d55ee6444c385d1291 (height 2099356) for 0 addresses
2021-10-23 01:04:59.111 [INF] LNWL: Catching up block hashes to height 2100000, this might take a while
2021-10-23 01:04:59.113 [INF] LNWL: Done catching up block hashes
2021-10-23 01:04:59.114 [INF] LNWL: Rescanned through block 000000000000002befeeec5aaa3b675ef421896c870e28669f00b0932e277eef (height 2100000)
2021-10-23 01:05:01.634 [INF] LNWL: Catching up block hashes to height 2100248, this might take a while
2021-10-23 01:05:01.637 [INF] LNWL: Done catching up block hashes
2021-10-23 01:05:01.637 [INF] LNWL: Finished rescan for 0 addresses (synced to block 0000000000000020384dfb92b0eb05a570ac842d26f33803382ad0ac7fafe631, height 2100248)

Can anyone give me some advice?

There si an issue opened in github to follow this. I’d suggest we all give our comments there so developers can look at it.