Recovering Wallet on Umbrel 0.5.0

I am trying to recover my wallet on the newest version of Umbrel. In past versions, it prompted me to enter my seed phrases or make a new account. Now it forces me to make a new account, and when I install Bitcoin Core and then the Lightning Node app, it just gives me a new seed. I cannot find anywhere to enter an old seed and recover my funds. (Blixt has also not worked for me on iOS. I am not sure why, but I want to try a full recovery on this new Umbrel). Is there any way to do so on the dashboard or only through SSH? Seems like prior versions of the software were much more intuitive, and this current version is so focused on all the bells and whistles they screwed up their core services. I really expect better from Umbrel. Any help would be appreciated.

1 Like

yeah this is something that was neglected during the 0.5.0 update. What are you trying to recover, on-chain funds? off-chain?

Looking to recover both On-Chain and LN wallet funds.

OK, do you have the seed phrases and the channel backup?

if you have access to the channels.db as well that can also be quite handy

I have everything I need (seed and channel backup). However with the recent update, I am not sure how to proceed. I previously tried to SSH, and tried to follow Darthcoin’s troubleshooting guides, however the organization of the file structure seems to have changed since his guide was published. I stopped as I did not want to screw anything up more than it is currently. I am Linux noob, but am competent enough to map out the file structure. As of now the Umbrel is running 0.5.0, and I have only downloaded Bitcoin Core and am currently resynching the blockchain. I have not yet reinstalled the LN node app or electrum server. How can I proceed with a recovery from here.

Alright, so to be able to reclaim your off-chain funds on 0.5.0 you’ll need the blockchain to have finished syncing.

Once that is done. use these guides to (try to follow them as closely as you can)

Restore onchain wallet for 0.5.0:

Restoring your offchain wallet for 0.5.0:

(source of these scripts was from contacting the umbrel twitter account in private message)

Seeing as you have an unencrypted backup file instead of an encrypted one from umbrel. When you get to running the restore scripts move the backup folder to ~/umbrel/app-data/lightning/data/lnd/

and then run the command: `~/umbrel/scripts/app compose lightning exec lnd lncli verifychanbackup --multi_file /data/.lnd/.

A successful verification will return



Finally if all is well with a verified backup then run the restorechanbackup command instead
~/umbrel/scripts/app compose lightning exec lnd lncli restorechanbackup --multi_file /data/.lnd/<your backup file name>

I performed this process this morning. In about 4 hours a majority of my funds are back. Wish you guys the best of luck.

P.S. You’ll need to wait a little bit of time after the block chain syncs because lnd need to run through the block chain and sync itself to it

1 Like

Cool thanks. I will try this. I am assuming I need to install the Lightning Node app prior to talking these steps?

that is correct

The restore script hasn’t been updated yet, so the following command downloads the right version

Well, that explains it. I literally just last night started the “use an old version” method and wiped my drive, so if that fails I’ll try this method.

It’s been a month, so I bet you most of my channels are force closed. I might as well start from scratch, but this time I’ll have backup power for the Pi.

Yeah I tried that, where you getting any responses from running the commands or was it a void?

1 Like

@HodlDoc @fresheyes. Just edited my comment with my status update. In short, worked for me. Wish you guys the best of luck

1 Like

Thanks. It looks like the “use an old version” is working, but I’m waiting for the sync to see for sure. I’ll confirm in a few days.

I’m running into an issue.

I did the secure copy step below:

MacBook-Pro-3:ln benjaminweissman$ scp /Users/benjaminweissman/Documents/Personal/Node/ln/my-umbrel-channels.backup umbrel@umbrel.local:~/umbrel/app-data/lightning/data/lnd/
umbrel@umbrel.local’s password:
my-umbrel-channels.backup 100% 6545 957.0KB/s 00:00

When I go to do the restore step however I get the following result:
umbrel@umbrel:~ $ curl | bash -s – ~/umbrel/app-data/lightning/data/lnd/
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 2946 100 2946 0 0 20458 0 --:–:-- --:–:-- --:–:-- 20458
Deriving keys…
mv: cannot move ‘/home/umbrel/umbrel/app-data/lightning/data/lnd/’ to a subdirectory of itself, ‘/home/umbrel/umbrel/app-data/lightning/data/lnd/channel-2512.backup’

Not sure where my mistake is or how to go forward. For the record I have an unencrypted backup file.

yeah ok. so it looks like you are trying to run the script that decrypts and move the encrypted channel backup file to the correct directory.

Good news is that because you are working with an unencrypted backup file, you don’t need to run that script.

all you need to run is:

mv <unencrypted channel backup file path>  ~/umbrel/app-data/lightning/data/lnd/channel.backup


~/umbrel/scripts/app compose lightning exec lnd lncli restorechanbackup --multi_file /data/.lnd/channel.backup

Hey DrWalrus, thanks for all the help. I went into the directories, and executed the mv command you recommended which I realize just renamed the file within directory I sent it to during the initial scp step. I just executed the final restore channel backup step, and got this:

umbrel@umbrel:~ $ ~/umbrel/scripts/app compose lightning exec lnd lncli restorechanbackup --multi_file /data/.lnd/channel.backup

[lncli] unable to restore chan backups: rpc error: code = Unknown desc = server is still in the process of starting

Should I just wait and re-execute the command in a little bit? My node had been off for a couple days, but I made sure to resynch up to the current block height before executing the channel restore command.

Hey HodlDoc, yeah it not only needs to wait for the blockchain to be in sync but also lnd needs to sync to the synced blockchain. should only take a few hours so give it a go. If it doesn’t work then maybe run the getinfo command to see the status of the sync

1 Like

I’m in the same situation. New Umbrel node installation and some money on Lightning wallet. I’ve the 23 word seed but I’ve not the Lightning node backup that was in my previous Umbrel installation.
Now I’ve a new node working but if I try to recover the wallet (using also Blue Wallet) I don’t see the credit on Lightning network but only 0 BTC.
There’s some possibilty to recover my Lightning credit?


Hello DrWalrus - Thank you for these instructions. I had to rebuild node from scratch after crash and been following these posts to recover. I was able to recover onchain funds with seed but having issues on latest version of umbrel to restore the channels of which I have a backup. Node is fully synced. Any assistance would be greatly appreciated…