Unable to enter the recovering seed in Umbrel 0.5.1

After several power outages, my SDD crashed and I have to recover my Umbrel node. In order to proceed, I need a way to recover my wallet. I hope I will then also be able to successfully restore my LN channels because that also fails now. I think I have tried all options I could find online, but did not succeed. Below details from my attempts using a Linux laptop and a ssh session to the Umbrel node.

Troubleshoot history

Start: Several power outages: System service failed

External storage service logs indicate external SDD can’t be mounted:

  • mount: /mnt/data: can’t read superblock on /dev/sda1
  • The unit umbrel-external-storage.service has entered the ‘failed’ state with result ‘exit-code’.
  • Jul 23 19:25:52 umbrel systemd[1]: Failed to start External Storage Mounter.

Fix 1: Repair external SDD

Connect SDD to Linux laptop and repair with fdisk and parted following https://www.linuxbabe.com/desktop-linux/fix-cant-read-superblock-error.
It turned out the SDD superblock could not be read but it could be recovered.

Issue 2: Failed to start containers

After starting the Umbrel node with a repaired SDD the containers failed to start.
Same result after booting the Umbrel node with a new flashed SD-card.

No fix

Tried several scenarios from getumbrel with no success, a.o. http://community.umbrel.com/t/error-failed-to-start-containers/4704/4

Start with new SDD drive and old SD-card

  • Install Bitcoin and Lightning Node

Issue 3: No option to recover / use my LN seed!

In order to speed up Bitcoin sync:

  • copy Bitcoin chain data from old SDD (blocks, chainstate and indexes folders from /media/USER/umbrel/umbrel/app-data/bitcoin/data/bitcoin,) to new SDD: /mnt/data/umbrel/app-data/lightning/data/lnd/data/chain/bitcoin/mainnet/.

Attempt 1: Reset user data and create new wallet (failed)

First backup seed and user files:

  1. cp ~/umbrel/db/user.json ~/backup/user.json
  2. cp ~/umbrel/db/umbrel-seed/seed ~/backup/seed
  3. cp /mnt/data/umbrel/app-data/lightning/data/lnd/data/chain/bitcoin/mainnet/channel.backup ~/backup/channel.backup
  4. Reset user data with
    sudo systemctl stop umbrel-startup && sudo rm -rf ~/mnt/data/umbrel/app-data/lightning/data/lnd/!(lnd.conf) && sudo rm ~/umbrel/db/user.json && sudo rm ~/umbrel/db/umbrel-seed/seed && sudo systemctl start umbrel-startup

After restarting the node, installing Bitcoin and Lightning node, there is still no option to recover my wallet.

Attempt 2: Use lncli to create new wallet (failed)

Delete existing wallet on Umbrel

  1. sudo systemctl stop umbrel-startup
  2. mv /mnt/data/umbrel/app-data/lightning/data/lnd/data/chain/bitcoin/mainnet /mnt/data/umbrel/app-data/lightning/data/lnd/data/chain/bitcoin/mainnet-old
  3. sudo systemctl start umbrel-startup

Start the on-chain recovery, follow the sub step “Starting On-Chain Recovery” of this guide

./scripts/app compose lightning exec lnd lncli create

→ does not work, these error messages return on consecutive attempts:

  • [lncli] rpc error: code = Unknown desc = wallet already exists
  • [lncli] rpc error: code = Unknown desc = wallet already unlocked, WalletUnlocker service is no longer available

Issue 4: Channel restore fails

Restore wallet

Following http://community.umbrel.com/t/how-to-restore-your-node-wallet/3602
Method 4: Install Zap wallet and recover wallet with Bitcoin seed: Better money
There is no option here to see or recover my channels so I have to proceed with my Umbrel node…

Rescue on-chain balance

Following https://github.com/guggero/chantools#channel-recovery-scenario

Restore Channels

Copy backup file:

  • scp [LOCAL DIRECTORY]/channel.backup umbrel@umbrel.local:/home/umbrel/umbrel/cb/channel-all.bak
    Recover funds:
    cd $wherever_you_installed_umbrel
    docker-compose exec lnd lncli restorechanbackup --multi_file /data/.lnd/channel.backup
    Check status with
    ./scripts/app compose lightning exec lnd lncli pendingchannels returns no pending channels.
    ./scripts/app compose lightning exec lnd lncli getinfo shows no existing channels.

FYI: I have ordered a UPS for the Umbrel node as this is really necessary to prevent this SDD crash and potentially loosing access to your channels…

Don’t quote me on that as I haven’t tried it, but if UmbreI isn’t working at all to recover your funds, I think you can also recover your funds on Blixt wallet as it runs a neutrino node (as long as you have your seed and channels backup). I’ve heard a couple of people that had an Umbrel node bricked on them that did recover their funds through Blixt with success.


Recovering seed seems to be working in older versions so I hope that someone knows how to get it working in 0.5.1…
In the meantime, I’ll look into the Blixt wallet as a backup plan.

1 Like

Guides need revisions, all directory and file locations changed in version 5 of Umbrel.

1 Like

True, what I noted:

  • ~/umbrel/lnd moved to /mnt/data/umbrel/app-data/lightning/data/lnd
  • ~/.lnd/data/chain/bitcoin/mainnet/ moved to /mnt/data/umbrel/app-data/lightning/data/lnd/data/chain/bitcoin/mainnet/

Also ./bin/lncli commands should now be executed using ./scripts/app compose lightning exec lnd lncli

With the help of Djuri and Kavin at Satoshi Radio I was able to create a new wallet using the recovery seed with below procedure, however Umbrel did not use this wallet before and after restarting the Umbrel services …

  1. start a ssh session with
    ssh umbrel@umbrel.local
  2. cd umbrel
  3. Delete all files in /app-data/lightning/data/lnd, don’t delete the directories but keep them empty (otherwise docker can’t recreate the directories later on)
  4. Stop all containers except lnd and bitcoind with
    docker ps --format '{{ .Names }}' | grep -v 'lightning_lnd_1\|bitcoin_bitcoind_1' | xargs -n1 docker stop
  5. Create a new wallet with
    ./scripts/app compose lightning exec lnd lncli create
1 Like

What worked was starting from scratch with a pre-0.5 Umbrel version. You can get the image from https://github.com/getumbrel/umbrel-os/releases. Now you can use the RECOVER option.


I tried the pre-0.5 I didn’t get the recover options straight to creating name and password. but I tried v0.4.18 and i got the recover options. I don’t see my funds yet, I’m guessing wait until finish synchronizing btc?