Raspberry stops working without any apparent reason

Hi everybody, i’m new here, happy to join this community!

I’m having a problem i cannot solve, but first:
I’m running Umbrel on my raspberry pi 4, connected via ethernet to my router, i’m using a crucial SSD w case, as suggested on the website. Every component is brand new. The power supply is original raspberry.
I’m running it with the fan unplugged, but it shows the same problem with it on and off.

The problem is that Umbrel stops working every now and then. I can notice it because the SSD’s leds are still, so i know it’s not operating. Then if i try to reach Umbrel it gives me this error:

This site can’t be reached

umbrel.local refused to connect.


  • Checking the connection
  • Checking the proxy and the firewall


It then tells me that I can:

Allow Brave to access the network in your firewall or antivirus settings.

If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.

I have my VPN off, i’ve already tried to reach it via IP (angryip), umbrel.local or SSH. Doesn’t work.
The only thing i can do is plug it off and on.
Every time I brutally restart it, it keeps working normally for some time, until not.
I’ve already tried to assign a static IP, i’ve not tried yet to reflash the SD.

Any suggestion?

P.S. i’m new to this technology and i’ve never been so good with technical stuff. I’m approaching this because I believe in this technology and I want to support it as much as I can. Thank you for your help, this is amazing and i’m so excited to be doing this!
P.P.S sorry for my grammatical mistakes.


1 Like

Connect a monitor to the HDMI output, look the messages, can give some hints.
If says something about ‘cant read blocks number NNNN’ (cant remember exact message), the SSD is corrupted.

ok i’m trying to connect it. I also have downloaded logs via trubleshooting, can it be useful? I’m not able to read it hehe :sweat_smile:

Can you ssh into your Umbrel and run dmesg?

I had massive issues on install. A new quality usb3 cable resolved the issue and it’s Rock solid now.

I could see loads i/o errors with dmesg before cable swap.

1 Like

hey thanks for your answer.
done that dmesg thing, now what?
it results in a shit ton of red lines, but i cannot comprehend them :sweat_smile:

also the SSD cable is the one suggested on the website, on amazon is descripted as a 3.0 cable. (Orico case)

Publish the Umbrel Logs here, so the experts can analyse.

But if you loose all communications with Umbrel, only resort is the monitor on the HDMI raspberry output.

unfortunately as a new member i cannot attach any file on here, neither i can copy and past cause it’s too big (that’s what she said).
I’ve seen many errors but i can’t understand. I’ve tryied to connect the power supply directly to the wall and done the troubleshoot again, it doesn’t show those errors again…
Maybe it was that.
Anyway if it’s useful i’d like to share the logs with you! Just tell me how hehe

hey! i’m now a “basic” member!
umbrel-1640514799414-dmesg.log (44.0 KB)

Post just a few lines from the dmesg… Or use pastebin

Seems hardware is good. So problem should be files corruption or soft bugs.
I had several crashes before, mostly files corruption and did some acts to prevent it. Put a no-break in ac line power and added a filtering capacitor in the usb to sata adapter (see image).
In the bugs front, I see many problems in versions 4.8 to 4.10 and don´t recommend them to do a install. V 4.7 seems the best to begin.

1 Like

From information of other threads, try to connect using umbrel-2.local, or umbrel-3.local

hey, thanks for your reply.
you know, idk how to do that, is there an easier way? i’m pretty noob.
Like do i need an UPS?
So from the software side is only files corruption? Do i have to reflash umbrel? What about the SSD, is it working properly?
Thanks a lot and happy new year!

When happens a power loss, files are corrupted both in board memory and in recording on SSD. Power loss can be caused by bad quality power supply, by bad contacts in connectors and for ac power line fault. So you should use an UPS, recommended power supply and don’t be playing a lot with RPi.

If files are corrupted, you must do a clean install. Exclude all partitions of SSD. Not common SSD breakes. Only the content (files) get broken.