Pi-Hole updating gravity doesn't work!

Hi Umbrellers.
I’ve got Pi-Hole up and running. Configured my router to use PI as default gateway instead of itself, so all traffic of my local network gets routed through Pi-hole.

That works.

But when I add an addlist url and update gravity:
DNS resolution is currently unavailable, and “DNS resolution is not available”

So I can’t update the addlist.

How can this be fixed? Anyone?

How do you configure the router to do that? Looking to try and can let you know how it goes

By telling the DHCP server of the router that it’s primairy DNS is the IP adress of PI-hole. So all requests of the clients that got a address from the DHCP server gets sent through PI-hole.
I’ve even totally removed the PI-hole app (I’m running it on a raspberry pi), and reinstalled. Even clean-out-of-the-box updating gravity doesn’t work. (And yes, I reverted the router settings without pi-hole connection again, so default settings). Still doesn’t work. Any suggestions?

1 Like

Please see fix here: Pi-Hole Not Working