Can't update Pi-hole from the dashboard

Hi, so I installed Pi-hole on my umbrel a few months ago, but it keeps going wrong, the adlist will show -2 ads instead of the usual 100k that comes installed by default, when I try to update gravity I get an error shown as

[✗] DNS resolution is currently unavailable [i] Time until retry: 120 seconds

But, it’ll block ads fine until today, where again it’s been set to -2 and still get the DNS resolution error.

I’m also unable to update the Pi-hole, I assume due to the DNS error though I have experience with Pi-hole I do not have experience with Docker but while troubleshooting I was able to figure out some commands to try to update the Pi-hole

Here is what I’ve tried so far:

sudo docker exec -u root -it container_name /bin/bash

I entered the Pi-hole container and tried Pi-hole -up, but it wouldn’t allow it.

sudo nano /etc/resolv.conf

I found that the DNS resolver was set to itself 192.x.x.x, so I set it to the server and added the secondary as (my ISP doesn’t support IPv6 yet)

Can anyone help? I’ve run out of solutions other than to wipe the SD and try again, but I’m sceptical of what will happen when I power up again… Took a week to sync the bitcoin blockchain.

Thank you.