Pi-Hole Not Working

The /etc/resolve.conf inside Pi-Hole docker container looks like this and thus it doesn’t work and does not download or update Gravity. Can someone please fix this inside the docker image or YAML file. Looks like we have an extra 1!

root@7a7bed7f73f6:/etc# cat resolv.conf
options ndots:0

I couldn’t find an editor inside the docker image, but I did this to fix it temporarily until the update is out:
Get the ID of your Docker process:

docker ps | grep pi-hole
7a7bed7f73f6 pihole/pihole:2022.07.1 “/s6-init” 33 minutes ago Up 33 minutes (healthy) 53/tcp, 80/tcp,>53/udp, :::53->53/udp, 67/udp,>3233/tcp, :::49154->3233/tcp pi-hole_server_1

Run a shell on your docker image:

docker exec -it 7a7bed7f73f6 /bin/bash

cd /etc
cat ./resolv.conf

Now we overwrite resolv.conf with the correct IP address:

echo “nameserver
options ndots:0” > resolv.conf

cat ./resolv.conf

options ndots:0

Now run Gravity Update and it works just fine.


Does anybody know how to update Pi-Hole using the “docker pull pihole/pihole” command. I’ve got the latest Image, but how to I tell the Umbrel to run the “latest” image with all of the necessary commands and config files? Where does Pihole get started from?

umbrel@umbrel:~ $ docker image ls | grep pihole
pihole/pihole latest 3ef04268449a 6 days ago 308MB
pihole/pihole 850e9721d3c2 2 months ago 295MB

Hi andelorean,

Our PiHole package is automatically updated through the App Store instead of having to run these commands. Its much easier this way!

Is there a specific reason you are attempting the manual version of this?

Thank you,

Because you have a bug in the configuration! The latest update BREAKS Pi-Hole and it can’t download the Gravity file. Please fix this inside the docker container!

root@16cfdc2e5598:/etc# cat resolv.conf
options ndots:0

This is still broken in the latest update and everyone is running Pi-Hole without a valid Gravity filter!

  • Docker Tag 2022.10
  • Pi-hole v5.13
  • FTL v5.18.2
  • Web Interface v5.16

Thank you for this fix, ridiculous that this still havent been fixed

1 Like

any luck?

1 Like

new update today, the problem is still there.

This is STILL broken, what is going on?

OK, so now in 5.14.2 /etc/resolv.conf is no longer writeable and this cannot be fixed. Umbrel team, the correct IP Address for /etc/resolv.conf is “” and NOT “”. Can you please fix this bug as Pi-Hole does NOT work without. You cannot update Gravity and download the blocklists. @Maxumbrel

1 Like

I finally have a FIX!!!
edit /home/umbrel/umbrel/app-data/pi-hole/docker-compose.yml
Add the last line “- DNS=”

  - DNS=

Run: “docker restart pi-hole_server_1”

Now you can update Gravity!!!

It also appears the NEXT version of Pi-Hole fixes this. I did a docker pull, fired up the latest and it now sets the nameservers to external name servers versus the loopback. Finger’s crossed.

1 Like

Ok, this is now editable once again. However, this must be done each time the docker container restarts. No clue where /etc/resolv.conf is configured/modified each time docker restarts.

OK, found the solution on Pi-Hole discourse. Make sure to set the local DNS, DNS Records names for pi-hole and pihole to

thanks for making this thread. I’m still having this same issue. Not sure why umbrel team hasn’t looked into this. I tried on a clean umbrel install with the version of pihole from the app store and out the box it’s broken. Added in the local DNS records and edited docker-compose.yml but I get the same result.

Any updates here? I still can’t get this to work. Is my only hope re-installing Umbrel completely?

Updated to Umbrel 0.5.4, uninstalled Pi-Hole, re-installed Pi-Hole, still getting " [✗] DNS resolution is currently unavailable"