Persistently change 4 TB SSD from MBR to GPT

Hi, I’m hoping someone can help with this as I’m coming to a dead end.

I want to use a 4 TB SSD with Raspbian Bookworm (Debian 12) on a Raspberry Pi 5 with the NVMe Base for Raspberry Pi 5 NVMe Base and install umbrel with the curl command.

I have tried this before with the NVMe base hat and Raspbian which worked surprisingly well with a 2 TB drive to make a server for something else but since MBR is limited to the 2 TB storage capacity it wasn’t a problem because I was within the limitations.

I also tried it with the 4 TB SSD I have with the curl command which worked until I realised it had changed from GPT to MBR limiting the full capacity to 2 TB instead of 4 and it keeps doing this every time I repartition the drive. So it should work if I can keep the partition persistent to GPT instead of reverting to MBR with the previous 0.5 version.

Does anyone know how to fix this?

This is my hardware:

I have exactely the same Hardware and I can only use 2 TB of my 4 TB SSD.

First I booted the device with Raspian from a 32 GB microSD card, then used the Pi Imager to write the Umbrel image to the 4 TB SSD and then rebooted the device without the microSD card. Umbrel is now booting directly from 4 TB SSD, but I have only 2 TB disk space available.

Does Umbrel support SSD drives with more than 2 TB ?
If yes, how can I fix this problem?

I don’t know. I made a topic for v1.1.2 but, I haven’t had a solution for that yet.