Pending channels w/o transaction broadcast to mempool

  • Running Umbrel on a Raspberry Pi 4

  • Umbrel is connected through Ethernet cable

  • I am using SSD

I tried to open three channels over a month ago and because there was an issue with my on-chain Umbrel Wallet, the OS was unable to open these channels. In fact, it did not even broadcast the transactions to the mempool.

I was able to fix the issue with my on-chain wallet and my funds are now safe, however, these three channels are still “pending” (its been over 1 month now!!) and there is just no way to even abandon them because Umbrel doesn’t allow its users to abandon channels.

I have attached a screenshots of the error message when I try to abandon these channels.


Hi, you can use the “lncli abandonchannel” command to remove those pending channels. But make sure first that you don’t have and funds in limbo.

Hi there, there are no funds in limbo as there was nothing broadcasted in the first place! The transaction ID of these channels are not found in the mempool. Please look at the error message I get when I try to abandon the channel. It seems like it’s only possible for developers

If you look at the description of the command there is an option… --i_know_what_i_am_doing or something like that… That worked for me

I have the same issue on mine. Been over 8 months or longer now. Funding TX was intentionally double spent as the channel was going to be too small. Tried lncli abandonchannel with no success.
Maybe someone has some advice?

Append –i_know_what_im_doing to your lncli abandonchannel command

1 Like

OMG! I cant believe it. IT WORKED! Thank you! here is what I did:

Abandon Channels on Umbrel:

ssh -t umbrel@umbrel.local

cd ~/umbrel/bin

docker exec lnd lncli abandonchannel --funding_txid ‘CHANNEL POINT FOUND IN RTL UNDER PENDING CHANNELS’ --output_index 1 --i_know_what_i_am_doing

1 Like

The above worked with one note to add, remove the colon # after the channel point

This doesn’t work
docker exec lnd lncli abandonchannel --funding_txid 12345654655434354354:1 --output_index 1 --i_know_what_i_am_doing

This works
docker exec lnd lncli abandonchannel --funding_txid 12345654655434354354 --output_index 1 --i_know_what_i_am_doing

With that I’m going to go celebrate having that transaction removed from my node. It’s been stuck forever!

1 Like

That sentence is not correct, you have to put sudo in front

This works
sudo docker exec lnd lncli abandonchannel --funding_txid 12345654655434354354 --output_index 1 --i_know_what_i_am_doing

Still it doesn’t work either, it doesn’t find the lnd container

Error: No such container: lnd