Umbrel funds "pending" after restoring LN channels


I recently had to reset my Umbrel node from scratch because of a corrupted SSD drive issue. I used the Umbrel restore menu to restore/force close my LN channels. Now it’s been 2 weeks since the force closures started, and all the channels disappeared from the payment channels section of the LN Umbrel app.

I was able to withdraw some of the funds from some of the closed channels, but unfortuantely, I still have 1.8M sats on-chain that I’m not able to withdraw to another wallet (they are currently marked as “pending” in Thunderhub). Is this normal that these are still pending, eventhough the channels have already been closed & disappeared from the Umbrel interface?


Here is what it looks like in Thunderhub in the “Chain” tab. I have 3 UTXO’s (totalling 1.8M sats) that have 0 confirmations after 16 days (as far as I can tell). Any ideas?

Hi @lafrite

After SSHing into your Umbrel, can you please share the output of the following script

~/umbrel/scripts/app compose lightning exec lnd lncli pendingchannels

It’s from this guide here

Thanks for your reply! Here is the output:

"total_limbo_balance": "0",
"pending_open_channels": [
"pending_closing_channels": [
"pending_force_closing_channels": [
"waiting_close_channels": [

It seems like the channels are all effectively closed, there are no funds “in limbo” from the point of view of the LN node, but my funds are still “pending” on-chain.

Has anyone ever had a similar situation?

Yes, I have been waiting for 2 pending close channels for more than a year after I restored my Umbrel node. The amount of sats has been stuck around more than a million, I remember.

Hi @lafrite

If these channel closes have been linked to an onchain transaction.
Can you say the current fee rate they are sitting at? Maybe we just need to bump these fees.

Here is what it looks like in Thunderhub: I’m not sure how to see the fees for the pending ones, as they don’t appear in the mempool anymore?

Thankfully the problem is now solved - after trying various “recover” points from different backups (which didn’t work), the Umbrel support team suggested that I just delete the Lightning Node app, reboot my Umbrel and re-install the app. And after doing that and waiting for the LN node to re-syncing, to my great surpris I was able to retrieve the on-chain funds funds.

I’m guessing the LN node got mixed up in terms of the information if had, for some unknown reason, and re-installing the app fixed it. Thanks everyone for your help!

Great to hear this worked, and thank you for sharing it here!

I’m in the same boat. How long did it take for the LN node to re-sync? Thanks…