Lightning channel stuck in "Waiting Close"

I initiated a channel close on Umbrel 2 weeks ago but it remains stuck on “closing”." If I select “view info” on the channel in RTL (Ride The Lightning), I can see it under “Waiting Close.” I have tried restarting my node several times.

If anyone can provide the command to force close the channel via command prompt that would help. I have managed to connect via C:\WINDOWS\system32>ssh umbrel@umbrel.local


Managed to figure it out. Executed the command via command prompt on desktop PC to force close:

Connect to Umbrel:

C:\WINDOWS\system32>ssh umbrel@umbrel.local

Execute command:

umbrel@umbrel:~ $ ~/umbrel/bin/lncli closechannel --force //(channel point with a space instead of “:” )

Transaction was re-broadcast successfully. “blocks_til_maturity” of 143 so presumably have to wait for these to clear before funds are returned.


@bitcarnicoin I have the same issue, but I’m confused what you meant by "channel point with a space instead of a : "

When I tried the command to force the channel to

I did ~/umbrel/bin/lncli closechannel --force 037cc5f9f1da20ac0d60e83989729a204a33cc2d8e80438969fadf35c1c5f1233b@ 9735

But I got the error [closechannel] unable to get funding txid: max hash string length is 64 bytes

So I tried the TXID I used for opening the channel

~/umbrel/bin/lncli closechannel --force <TXID>

The error from the logs was [/lnrpc.Lightning/CloseChannel]: channel not found

I’m not sure what I’m doing wrong here…

Just kidding! The channel point is found when you enter ~/umbrel/bin/lncli pendingchannels

And look inside the waiting_close_channels array for channel_point… from there it’ll be a string like


And to close the channel it’s like you said

~/umbrel/bin/lncli closechannel --force 851ddc0900b775ff4afbd12ed4c8c003456eaea862ba96664344b06a04eec7c5 1

Hope this helps someone in the future!


One more thing, after the closechannel command works, you can see when your funds will be released in the maturity_height value inside the pending_force_closing_channels array.

~/umbrel/bin/lncli pendingchannels

"pending_force_closing_channels": [ ...."maturity_height": 694303,


@Mikey @bitcarnicoin - Thanks guys, this helped me as well!


thank you this helped me a lot.

@Mikey, after running the force close command there was a brief pause then nothing. Ran the pendingchannels, but nothing shows up in “force_closing”. How long might I need to wait?

Not seeing “maturity_height” either.

Also, local and remote balances are both shown as “0”?

@zipfastlnd i have exactly the same issue
did you find a solution?

Not really. Some explorers showed the channel as still being active while others showed it as non-existent. I waited a few weeks then still found it to be inactive by most accounts, so I dropped it.

Currently, I’m working on a cluster-computer to make sure this doesn’t happen to me again! Even if the setup experiences hardware failures, the bitcoin clock should keep on ticking…

I also have this exact problem @zipfastlnd @mugiwara . I am attemping to find a solution. But did you find a solution?

This aspect is very well explained in the troubleshooting guide and what you can do about, but seems that users don’t want or don’t have the patience to read that manual, just asking over and over same questions.


You are incorrect, it is not very well explained in the troubleshooting guide.

I already checked the troubleshooting guide and it details that you should expect to see a “maturity_height”. As you can see from the picture above in this thread, there is no “maturity_height” listed.

I carried out the force close as this thread and the guide states, and I still see no maturity_height. The channel also doesn’t move into “pending_force_closing_channels” like you may expect, it just stays in “waiting_close_channels”.

So from trying to do everything “correctly” and “reading the manual” and “having patience” - there’s still problems.

You said yesterday you always say the truth. So here’s some truth - You shit on people for not reading guides, having no patience and being noobs - which makes you just come across as an awful person. Many of your guides have mistakes and errors making them difficult to understand or even more confusing. Your behaviour is detrimental to the growth of bitcoin, lightning and the Umbrel community and you make the culture around here downright awful. There’s much nicer communities to go to and that’s exactly what I’ve done and found much more help from people who aren’t just plain old grumpy arseholes.


You are welcome to write better guides. Are you capable to do that? Or just complaining?
I gave you the right information how to proceed with channels in closing. If you are not capable to understand how LN works then sorry but these things are not for you.

I am not here to talk nice with you, this is not a “be nice” contest. I don’t have time to find the words that make you happy. Take it or leave it.

@zipfastlnd @mugiwara

There is a tool called “chantools” which may help your scenario if you’re still having a problem. I’ll paste my problem I had and it’s solution below incase it is useful to help you.

  • I initiated a new channel opening on the lightning network with a known node of 1mil sats capacity
  • My Bitcoin wallet had 4mil sats withdrawn
    • 1mil for the channel
    • 3mil UTXO (Unspent Transaction Output)
  • The channel opening transaction was broadcast to the bitcoin network and was sitting unconfirmed
  • Whilst the channel opening transaction was sitting unconfirmed:
    • I accidentally deleted folders on my Umbrel node that I definitely shouldn’t have
    • I turned off my node, reflashed my SD card, and restarted/reinstalled my entire node with my 24 words
    • I executed the restorechanbackup command from my most recent channel backup (cd ~/umbrel && ./bin/lncli restorechanbackup --multi_file /data/.lnd/channel.backup)
    • I failed to take a channel.backup at any point during all of this (so had no backup of the pending channel)
    • I failed to backup anything from my node before restarting/reinstalling it
  • After a day or so, all my channels force closed, however the 4mil sats from the channel opening transaction were “lost” and I couldn’t see the channel on my end
  • I contacted the Umbrel backup team, and tried 2 backups which could have possibly contained the pending channel, and I executed that restore but still couldn’t see the pending channel (
  • I contacted the node I setup the pending channel to, and they were able to successfully force close the channel, but this did not change anything on my end, I still couldn’t see the channel or UTXO
  • I tried to restart my umbrel node with reset-wallet-transactions=true - unfortunately this didn’t find the UTXO or channel
  • I was then introduced to something called chantools ( - MAKE SURE YOU INSTALL THE NEWEST VERSION by changing the example text from v0.7.1 in both locations!!! (Umbrel on a raspberry pi4 requires ARM64 version.)
  • The author indicated that:
    • Since the other node force closed, the “missing” channel funds could now be swept by me as I have the seed.
    • Unfortunately lnd doesn’t (yet) pick up on such funds automatically.
    • And because my umbrel channel backups didn’t contain the new pending channel yet, I would need to do it manually.
    • Fortunately for such cases the author built the “chantools sweepremoteclosed” command. (
  • I ran the “chantools sweepremoteclosed” command whilst SSH’d into my umbrel node:
    • Making sure to adjust the fee rate to something sensible (4 was fine for me at the time)
    • Making sure to specify my own bitcoin address for the sats to be swept to (I used my umbrel node bitcoin address)
    • It will prompt you in the CMD windows for your 24 node words (I had nothing to lose and the tool indicates your words don’t leave your device)
  • This command was successful in recovering my 1mil sats channel capacity
  • To recover my 3mil UTXO, the chantools author indicated the “chantools genimportscript” command will work (
  • Other advice indicated that using electrum desktop wallet would be easiest to import the private keys the command can generate
  • I therefore executed the command with “-- format electrum” (chantools genimportscript --format electrum \ --recoverywindow 5000 \ --lndpaths)
  • This provided a file on my umbrel node
  • I copied this to my desktop by running a CMD command on my local desktop computer such as (scp umbrel@umbrel.local:/home/umbrel/results/genimportscript-2022-04-05-11-00-50.txt C:\Users\redacted\Desktop\genimportscript-2022-04-05-11-00-50.txt)
  • I then installed electrum desktop wallet, and copied the private keys from the file when I booted up electrum for the first time (I had to select the option to create a wallet from private keys)
  • In about 1 minute, it had a balance of my UTXO transaction (thought I understand this could take longer)

That’s it. All my funds were recovered. I’d like to thanks again the folks that helped me out, so thank you!


Thank you for this answer. Using Lightning Shell (add-on app via the Dashboard on Umbrel) to perform this force close of a stuck channel has been the only solution for me recently. Somehow, moving my Umbrel to a different network IP address totally killed SSH, and using Lightning Shell to force close my stuck channel is the only way for me to get all my sats back from my Lightning channels before rebuilding my Umbrel. How else will I get SSH working again?! :slight_smile:

I like my Umbrel on Raspberry Pi 4 box a lot - very easy to use, generally - but I’d like to continue to see more stability to handle these one-off situations I’ve found myself stuck in recently.

Agree with you, Diiikco. @DarthCoin has done lots and lots of work to inform, which is appreciated, but yes, many times the individual interactions seen on forum posts is rather rude and condescending, as if Darth’s writing and instruction is always infallible, and it’s not.

There will always be edge cases and unexpected errors with systems so complex as hardware, software, internet, networking, security, Bitcoin and Lightning networks, and how it all fits together. That is A LOT of potential failure points for any individual user to have to navigate, and for @DarthCoin to behave as though everyone who hasn’t encountered many of those failure points before is a retard is rude, at best.

1 Like

Will this also work if the other node initiated the channel to me? I seem to have 2 missing channels after restoring a channel backup and one stuck on waiting close with 0 limbo balance reported. ( which is not correct). If they force close to me will I be able to get the sats balance on my side of the channels back or are they lost forever? I’ve been fighting with this for 4 days and it seems no one is able to answer my question, losing my patience and my mind over this. :confounded:

I used the original command and there was an Deprecation notice as below.
My Umbrel version is the most latest.

"~/umbrel/bin/lncli closechannel --force

  • *** Deprecation notice ****

  • In a future version of Umbrel, ‘lncli’ will be removed.*

  • Please instead use:*

  • ./scripts/app compose lightning exec lnd lncli "*

Anyone helps provide the updated command, pls.

1 Like