NVMe SSD not recognized in 1.2

I’ve waited long for the NVMe support but Umbrel on my RPi5 is still not recognizing. I’ve tried both the mini PCIe strip on the RPi5 and USB (both clean installs) but nothing. I’ve also tried the lsblk command and NVMe drive was not shown in neither cases. What should I do?

Did you make sure to insert the ribbon cable the correct way? The ribbon cables are not keyed meaning you can install it backwards.

What’s the board you’re using for the NVMe?

Hey @Mahojakotyc -

As @Cali_Fornia suggests, definitely check that the ribbon cable is installed correctly. They can be pretty finicky.

Also, you’ve probably run across these instructions: Raspberry Pi 5 ‐ Boot from NVMe or USB · getumbrel/umbrel Wiki · GitHub

But if you haven’t, please take a read through. There are two main complexities with NVMe on a Pi in general to be aware of:

  1. NVMe quality and Hat compatibility:

  2. If you have an early version of the Pi 5, you may need to update the bootloader firmware in order to be able to boot anything from NVMe

Let me know how it goes and we can troubleshoot further if needed!

Does anyone know why you can’t run it on the Pi4 with an NVMe?
With a bootloader update an NVMe is also compatible there.

As far as i know, the Pi4’s don’t support NVMe’s natively, but you can do it if you had a card/adapter/hat that goes from USB3 to NVMe. There isn’t enough lanes on the Pi4 that can support a NVMe at noticeable speeds (I think it only runs at one PCIe lane, meaning USB3 is faster), but there is one on the Pi5. With updating to 1.21, I definitely noticed a much snappier and responsive time using an NVMe compared to the USB3 SATA SSD that was on it with Umbrel 1.0.


yes you can, I’m running on RPi4 4gb, 1tb NVME on argon. issue is 1.2.1 update, downgrade to 1.1.2 and all is working as before.
it only took me 6 hrs to figure this out.
sounds like umbrel is moving away from DIY , or just bad update. ultimately there’s always start9

1 Like

Thanks for that! It really seems to be the case that 1.2.1 broke something. I just flashed the 1.1.2 on an external drive and it bootet wonderfully over USB3 on my Argon Pi 4. Then proceeded to update to 1.2.1 and it doesn’t boot anymore.

I’ll second @aeon, I updated to 1.2.1 and tried to switch over to WiFi, and now I can’t even get the Pi to recognize my NVMe board or drive. I’m significantly displeased, to say the least.