Failed connection of the Nostr Relay on working on Tor

Hi Umbrel Community:

(Specifications of my Umbrel Server)

  • Umbrel 0.5.1, Raspberry Pi 4 8MB on Ethernet Cable to connect internet
  • SSD 1 GB WD 2280 in a Argon M2 Case

This is the first day of the Nostr relay on Umbrel. Amazing work of the team. But I can not connect my relay to or Ninja web browser server. I’m working in Tor Browser on my local network. I tried in firefox as well but I can not make it. I have a VPN working and turned on and off and it is the same.

Does anyone have some tips or solutions? Thanks :upside_down_face:

I am having the same issue with iris. I have not tried any other clients.

Has anyone had success in connecting iris to their node?

1 Like

I am wondering why iris will not connect as well. Damus app on my cellphone works fine. Not running tor for this setup even. Ubuntu, chrome, core i5 lenovo thinkpad running umbrel. Testing things with a separate windows laptop, same business.

1 Like

On Amethyst it works fine connected to Tailscale vía IP.

Hey y’all Iris doesn’t look to have ws:// support yet, Nostr Relay app will require the client has ws:// support, confirmed support for Damus, Astral, and Amethyst

We do have some active development on this so will ping if there are any updates!

1 Like