Node unreacable after updating to V0.5

Hi there,

after the update to v0.5 I’m unable to reach the umbrel node.
(Never was able to reach it after the update)
When using Chrome to “open” umbrel.local I get the following error message: “DNS_PROBE_FINISHED_NXDOMAIN”

It doesn’t even show up in the network anymore.

I already tried restarting it manually, but that didn’t work either. (the raspbarry pi stays on)

What can I do?

1 Like

Same here - getting: " umbrel.local ’s DNS address could not be found. Diagnosing the problem."

Can’t SSH - seems node is dead? I guess restore from the ground-up? Good thing I saved my LN channel state, I guess?

So after nobody could help I decided to reflash my sd card. After doing that the node startet up just fine and all my data was still there.

But for many hours now the node does not show any new blocks.

See logs attached.

What can I do?umbrel-1654790223997-debug.log (43.3 KB)

Hey @J0nsan, thanks for going through the solutions with me in DMs, glad we got it sorted.

For anyone else who ends up here, it was filesystem corruption making Bitcoin Core unable to start, reinstalling the Bitcoin Core app resolved the issue.

The corruption was likely caused by the failed Umbrel update, we’re doing our best to get to the bottom of how this happened to make sure it doesn’t happen again!


@J0nsan - so by “re-flashing” did you just re-etch the SD card with the 0.5 version of Umbrel? Re-enter seed, and restore LN channels from backup? Just want to make sure I’m going the right direction here -

by “re-flashing” did you just re-etch the SD card with the 0.5 version of Umbrel?

Yes exactly!

You just need to:

  • Power off your Umbrel
  • Remove SD card
  • Flash Umbrel 0.5
  • Plug SD card back into Umbrel
  • Power on Umbrel

You shouldn’t need to recover Lightning channels, all your data should still exist on your SSD.

1 Like

Are you facing the same issue @Schneider?

You did the update to 0.5 and then your device became unresponsive?

If so could you also let me know what size your SD card is for your Pi?


1 Like

@lukechilds - yes, unresponsive after 5.0 install. 32GB SD Card - my entire build is from the parts list on the Umbrel site. :slight_smile:

Thanks @lukechilds - that did the trick, back up and syncing blocks, appreciated!

Brilliant @Schneider glad to hear it!

Would you also mind letting me know how long ago roughly you originally setup your Umbrel? Just trying to find a common theme between people experiencing this issue. Thanks!

Roughly April of 2020 - let me know if you need more details, happy to provide

I have the same problem since many updates ago.
Can’t access umbrel.local from my notebook, however I can access it through safari through mi iPhone.
Once I tried installing a previous version and suddenly it worked from my notebook, and then again it broke down the access.
What would be the advise here? What is the best version to install so that I can access it normally from my notebook?

Same thing happened to me. reflashing to see if that works.

Hi there,

I had the same problem, where I was unable to access my node through umbrel.local and I sat to read about possible solutions. I found this guide How to set a static IP for your Umbrel machine

This particular part of it resolved my problem and I’m now able to access the node through the umbrel.local

Option B - setup a fix IP in your RPi settings

  • use Windows Powershell or Putty to enter SSH into your Rpi
  • type ssh umbrel@umbrel.local or ssh umbrel@yourRpi-IP` if you know that dynamically assigned IP (see previous point listing IPs in your LAN)
  • will ask you for a password, BUT YOU WILL NOT SEE IT. Just type your user password for Umbrel and press ENTER.
  • once you are in, configure the static IP address for the Pi, the gateway path and a DNS server. The configuration for the DHCP client (Pi) is located in the /etc/dhcpcd.conf file:

sudo nano /etc/dhcpcd.conf

The following snippet is an example of a sample configuration.
Change the value of static routers and static domain_name_servers to the IP of your router (default gateway, see Option A).
Be aware of giving the Raspberry Pi an address which is OUTSIDE the range of addresses which are assigned by the DHCP server. You can get this range by looking under the router configurations page and checking for the range of the DHCP addresses. This means, that if the DHCP range goes from to you’re good to go with the IP for your Raspberry Pi.

Add the following to the /etc/dhcpcd.conf file:

#Configuration static IP address (CHANGE THE VALUES TO FIT FOR YOUR NETWORK)
interface eth0
static ip_address=
static routers=
static domain_name_servers=

Restart networking system sudo /etc/init.d/networking restart

NOTE (Thanks @LoboGuara): If you update umbrel by reflashing a new version in SDcard, dchpcd.conf file is reseted. So make a copy of that file before you reflash your mSD card or edit again with your modifications before you start your node.

The other problem I’m facing now is that the bitcoin node app is not syncing and it stays at 99.96% with 0 peers.
My node is unreachable through Tor too.
I run a troubleshoot from the interface but it did not detect that anything is wrong with the node. I’m uploading the log produced from the troubleshooting. Help will be appreciated as I’m a newbie in this. Thanks
P.s can’t upload the report as an attachment as I’m a new user. Here is a link

Hey @lukechilds, I’m having the same issues and I’ve reflashed 0.5.0 (didn’t work) and also tried flashing a previous version, 0.4.18, and that didn’t work either – Still getting “DNS_PROBE_FINISHED_NXDOMAIN” when trying to access umbrel.local and unable to SSH into it. Any recommendations on how to move forward?

Exactly the same thing happened to me. My Samsung SSD developed bad sectors which made the bitcoin docker container continually restart.

I fixed it once but then after a few months it happened again! More new bad sectors.

The solution was simple. Buy a new SSD (this time a Crucial SSD). Copy the old SSD umbrel directory onto the new SSD. Delete the blockchain data and start Umbrel.

One of the great things about the containerised architecture of Umbrel is that all you need to do is copy the umbrel directory onto a new disk and it will just work. Nothing is really installed on the host OS.

1 Like