Node stuck since upgrade to 0.4.6

I upgraded to 0.4.6 about 6 hours ago and my node has not been working since. I’ve restarted a few times but I am stuck. Bitcoin Core says 100% but also says last block was 6 hours ago.

I am spinning up a brand new node … All new hardware and it doesn’t seem to be syncing at ALL… Only been about 20 minutes but zero blocks have synced

same issue with me since yesterday. My bitcoind logs are filled with ThreadRPCServer incorrect password attempt from which is LND’s container IP. LND’s logs are filled with wallet locked, unlock it to enable full RPC access.

I’ve logged into the LND container and ran lncli unlock and it accepted my password, but then it locks the wallet and shuts down the container, rinse and repeat. It’s stuck in this loop and I have no idea how to fix it (attached is the log from LND right after I input my password successfully). The crazy thing is I don’t have any LND channels open, I only have BTC in my BTC wallet but it’s blank because of LND. Not good.

lnd-log.txt (3.4 KB)

1 Like

I also have the same issue. My node is in perpetual sync mode with both wallets. Flashed the micro sd, but that failed to fix anything. I upgraded to 0.4.6 too. Before this happened, I went into ssh to change my alias, so that might be the problem also. Anyway, do I need to re-initialize my ssd and download the whole bitcoin core from scratch now? I have the seed but an RTL backup that’s missing a day’s channel data. And should I re-lash with 0.4.3 (which is still in my download file)?

1 Like

I am starting from scratch and spinning a node with new hardware using my seed phrase :crossed_fingers:

@NoBS and do you get it up and running?

1 Like

Check out this previous thread. Stuck at "deleting previous images" updating 0.4.5

No I am still struggling

So I got an “official” raspberry pi power supply and it helped a little… the dashboard now shows my BTC and lightning balances and starts syncing the blockchain and gets as close as 30-50 blocks to being current but then restarts at the same place from about 2 days ago when I upgraded.
Also I am no able to access the node through SSH as it tells me I have the wrong password

I have been in this for about 4-5 days now.
I am just stuck in a syncing loop. It starts on a block about 5 days ago (when I upgraded to 4.6) and gets to about 20 blocks from the current block and then starts over again…
I just tried a manual update to 4.6 using SSH but that didn’t seem to matter either, I am in the same loop.

I gave up trying to save my previous node instance. Next, I re-flashed Umbrel OS with the same SSD which is 100% synced and entered my 24 words, but still my sats did not show up. I tried re-indexing bitcoind without success.

My next step, I flashed a fresh Umbrel image again and started with a separate blank SSD. I let it fully sync before opening the web GUI and attempting to recover with my 24 words. It’s now been more than 24 hours since it reached 100% sync and it has only found my first transaction of 17,000 sats, I’m still missing 424,000 sats. What the heck? What is the next step here? Where is support?

That sucks, I was able to get mine running again by downgrading back to 4.3. Support is a little hard to find but hopefully that will improve with the seed money Umbrel just got.

It looks like umbrel can’t make an working update anymore.
Too bad, but fortunately there are alternatives to umbrel


I was able to get my issue fixed. It turned out to be BlueWallet that creates a different public address for the wallet which one of the underlying containers has issues with. I transferred the sats from my BlueWallet wallet to my Umbrel wallet then delete the BlueWallet wallet and my sats transferred back into Umbrel, minus transaction fees which is fine by me. It’s surprising that there isn’t any documentation anywhere about this.