Node not syncing the blockchain

Hi there,

I’m facing a problem where my node is not syncing with the blockchain and it seems like it’s disconnected. I can access the node through umbrel.local now (couldn’t previously but will share more on this below) and I can see that I’ve lost all my peers in the bitcoin node app and is not syncing for the past 4 days. LND is not opening at all, also cannot access the thunderbolt app. Tried to connect to my node through Tor, but I couldn’t.

Now I’m not a power user, nor a heavy user. Deployed the node out of the desire to secure and decentralise the blockchain a little more, and out of enthusiasm to learn more. At a later stage I’ve decided to use some of my bitcoin to open a channel on the lightening network.

I will try to put some stuff that I did and happened in a chronological order to try and give some background of what’s been going on, and will share a link to the troubleshooting log from the node itself down below.

So in the middle of this month we traveled to my parents and they don’t have internet access over there, and I have that hybrid hub from BT and EE here in the UK, where with the EE device you get a 3G/4G signal form their mobile network and transfer it over to the BT router, then it gets shared as a wifi signal. That means that the node was not connected for 3 days or so.

When we got back home and connected to the cable I’ve checked the node and It synced with the blockchain fine. Downloaded and updated the umbrel os too (to 0.5.0 I believe it is).

In the following days I transferred some Bitcoin over the mainchain in anticipation of opening a LN channel.

A few days later I opened up a channel with Kraken.

Then a day or two later I was unable to access my node through umbrel.local and I sat to read about possible solutions. I found this guide How to set a static IP for your Umbrel machine

This particular part of it resolved my problem and I’m now able to access the node through the umbrel.local

Option B - setup a fix IP in your RPi settings

  • use Windows Powershell or Putty to enter SSH into your Rpi
  • type ssh umbrel@umbrel.local or ssh umbrel@yourRpi-IP` if you know that dynamically assigned IP (see previous point listing IPs in your LAN)
  • will ask you for a password, BUT YOU WILL NOT SEE IT. Just type your user password for Umbrel and press ENTER.
  • once you are in, configure the static IP address for the Pi, the gateway path and a DNS server. The configuration for the DHCP client (Pi) is located in the /etc/dhcpcd.conf file:

sudo nano /etc/dhcpcd.conf

The following snippet is an example of a sample configuration.
Change the value of static routers and static domain_name_servers to the IP of your router (default gateway, see Option A).
Be aware of giving the Raspberry Pi an address which is OUTSIDE the range of addresses which are assigned by the DHCP server. You can get this range by looking under the router configurations page and checking for the range of the DHCP addresses. This means, that if the DHCP range goes from to you’re good to go with the IP for your Raspberry Pi.

Add the following to the /etc/dhcpcd.conf file:

#Configuration static IP address (CHANGE THE VALUES TO FIT FOR YOUR NETWORK)
interface eth0
static ip_address=
static routers=
static domain_name_servers=

Restart networking system sudo /etc/init.d/networking restart

NOTE (Thanks @LoboGuara): If you update umbrel by reflashing a new version in SDcard, dchpcd.conf file is reseted. So make a copy of that file before you reflash your mSD card or edit again with your modifications before you start your node.

The other problem I’m facing now is that the bitcoin node app is not syncing and it stays at 99.93% with 0 peers. As I mentioned earlier the node is inaccessible through Tor too.

I ran a troubleshoot from the interface but it did not detect anything wrong with the node. I’m uploading the log produced from the troubleshooting here

If you have any questions I will try my best to answer them.

Any help will be greatly appreciated

Did you have any luck fixing this ? I’ve had the same problem … for 4 months now.

Hi, yes I uninstalled and installed the LND app from the dashboard. That worked for me. Put my seed phrase in took my sats out and will not return back until this is made more user friendly. Obviously there was no support at all from the community so don’t see the point to try and fight with it. I left the bitcoin node tho. That doesn’t require any managing.
Good luck

1 Like


I’m having an issue for the past 6months we’re my bitcoin node won’t sync. Now I’m having an issue where it stopped at 99.94% and not connected to any peers. If I restart Umbrel completety it fixes the issue but I’m hoping if there’s an alternative way. Running umbrel on a raspberry pi 4, 8GB RAM and 1TB SDD