New Umbrel 4.0 - Nextcloud App

New Umbrel 4.0 - Nextcloud App
I need to access a file with a different device and I get the following error…

"Access through untrusted domain
Please contact your administrator. If you are an administrator, edit the “trusted_domains” setting in config/config.php like the example in config.sample.php. "

How can I change the config.php file ?


I’ve figured out how to get there.
I can now access files shared to the outside.
I will post tomorrow the solution.

1 Like

I have created account in Tor browser and can access from outside. Android app works with Orbot. It’s slow for handling big files. Not ideal, waiting for solution how edit trusted domains.

The solution was as follows:
Nextcloud installed on the Raspbery Pi.
I used a Windows computer with SSH installed to access the RPi.
I used “find / -name config.php” and the following path resulted:
I edited with “nano” and added trusted domains and it worked perfectly.


Working! Thanks!

When you say you “Added trusted domains and it worked perfectly.” what did you add?

I’m looking at config.sample.php, list of IP addresses or domains but unclear what this means for editng config.php. Do I add the Tor onion address generated by Umbrel? *.onion?

OK, here’s what worked for me. I’m a noob so if someone else reponds and says this is disastrous, please follow them. Also, this functionality should be default so no more noobs like me need to edit.

  1. Login to RPi as umbrel
  2. In terminal enter:
    sudo nano umbrel/app-data/nextcloud/data/nextcloud/config/config.php
  3. In the section of the file that mentions ‘trusted_domains’, add an element to the array that allows ‘*.onion’ (any onion domain (may be a massive security hole or something, but I wanted to accommodate if my onion url changes)

Add this line:
1 => ‘*.onion’

Your file should look like this:

'trusted_domains' => 
array (
0 => 'umbrel.local:8081',
1 => '*.onion'
  1. Save the file (control O, then hit return)

Now that I’ve got NextCloud accessible over Tor, I want to connect it to one of the NextCloud apps on iOS. But it looks like they don’t support Tor.

What are you all doing with NextCloud once you get access over Tor? Are you just accessing it in Tor browser or something?

1 Like

I don’t know about on IOS, but on Android you have to run an app to enable the TOR network (Orbot) and add Nextcloud to the list of Tor enabled apps

Ah okay. It looks like iOS has no way to enable Tor systemwide – only download and run one-off apps like “Tor Browser” etc. Looks like iOS + NextCloud over Tor is DOA.

Worked, but if you want to do it safer: use the exact .onion url that connects to nextcloud via tor in the config file. That way ONLY that url can get in. (simply connect to nextcloud via tor to find that url :wink: Copy, paste, writeout, Done.

1 Like

I can´t connect to nextcloud from local network devices.
“Access through untrusted domain”

What do I have to enter so that I can access it from the local network?
Here my config:

‘trusted_domains’ => array ( 0 => ‘localhost’, 1 => ‘umbrel.local:8081’, 2 => ‘xxxxxxxxxxxxxxxxxx.onion’),

Greetings to the Community

I got it:
add the local IP address of the raspberry pie and it works:

‘trusted_domains’ => array ( 0 => ‘192.1xx.1xx.xx’, 1 => ‘umbrel.local:8081’, 2 => ‘xxxxxxxxxxxxxxxxxx.onion’),

found another solution :

Add node IP into your hosts file

  • Go to the hosts file located into: C\Windows\system32\drivers\etc\ If you can’t see it, go to view folder options and select “show hidden files and folders”.
  • copy it onto your desktop and start editing with notepad
  • add the following line:

192.168.x.x umbrel.local

(replace 192.168.x.x with your local IP assigned for your node)

You can use tailscale vpn available in almost all OS, creates a personal network available to connected devices in the account, now available in Umbrel 0.4.14

1 Like

I’m a new user. Just installed Nextcloud on my Umbrel but can’t get into the app. When I click OPEN in the Umbrel interface, the error message says “access through untrusted domain” and advises changing the trusted domain in config/config.php and sends me to documentation that I don’t fully understand. Where do I find that config file on an iMac (OS 12.4)? And what do I do when I find it? The replies here explain how to proceed in Windows. Any Mac users who can help?

The sample file does nothing. Open config.php with nano /home/umbrel/umbrel/app-data/nextcloud/data/nextcloud/config/config.php and go to [around] line 30 where you’ll see the array of 'trusted_domains'. Mine already had the onion link added, and you can add more using the same format.

I am trying to access my Nextcloud via a remote device running Tailscale. I can get into my Umbrel just fine, but when I try to launch Nextcloud, it tells me I am trying to access it through an untrusted domain, and that I need to add the domain to my list of trusted domains in my config.php file.

I followed the instructions that the OP posted for how he did this, but after finding the path and trying to edit it with nano, it returned an error saying “Error reading /umbrel/app-data/nextcloud… config.php: Permission denied”. Any ideas about why I can’t seem to access the config.php file, or why I need to when accessing my Umbrel via Tailscale?

NVM. I figured out that I had to use the command “sudo nano” to get it to work properly. Edited the config.php by adding the IP address from Tailscale and I am up and running to access Nextcloud from any device.

1 Like