My Raspi 4 load is going crazy after full sync

I’ve set up my node last year. Due to moving places it was turned off for around 6 months. Got it up and running again last week. Updated to the latest version of Umbrel and node got fully synced again.

Now I’m experiencing these crazy high loads (see screenshot) and can’t access my node through the web.

Done so far:

  • I’ve reinstalled Umbrel on the SD card, but still the same problem.
  • I ran an fsck on the USB attached SSD, nothing wrong.
  • I’ve replaced the USB cable of the SSD, still the same problem

I’m running the Raspi 4 with original power supply.

Anybody any idea what I could try? I’m out of ideas.

High load average but at least on your screenshot your CPU is not that much loaded.
Perhaps it has to do with the disk you’re using. Not sure about htop but in regular top you can also see % wa which is time spent on waiting for IO on disk.

This is what top says:

yeah 95% wa. Means your disk is probably overloaded with too much access at the same time.
Maybe it’s not SSD? or broken somehow

I see now you already said it’s SSD.
Maybe check for IO errors in dmesg and also maybe some clues of overly active containers in docker stats

Seems indeed something not right with the USB - SSD connection?

Yeah that’s not supposed to be there :slight_smile:
Are you using the original power source for rPi 4?
If so, I’d consider getting a replacement disk

1 Like

Yes, I am. Will try changing disk case. If that doesn’t work I’ll get another SSD. Thanks for responding.

1 Like